Support » Plugin: 12 Step Meeting List » ?tsml-day=any returns No meetings were found matching the selected criteria

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Oclair

    (@oclair)

    examples of meetings not listed in archive
    https://www.navienna.com/meetings/new-freedom-en-de/
    https://www.navienna.com/meetings/neues-meeting-hu/
    https://www.navienna.com/meetings/newcomer-meeting-de/

    I’ll remove linking the plugin on the menu until it’s able to print the meeting archive dataset

    WordPress 5.4.2
    12 Step Meeting List Version 3.7.2 by Code4Recovery
    Akismet Anti-Spam Version 4.1.6 by Automattic
    Classic Editor Version 1.5 by WordPress Contributors
    Event Organiser Version 3.10.0 by Stephen Harris
    http-syndication Version 1.7 by Thierry.Vieville@inria.fr
    Icegram – Popups, Optins, CTAs & lot more… Version 1.10.41 by icegram
    Jetpack by WordPress.com Version 8.7.1 by Automattic
    Page scroll to id Version 1.6.7 by malihu
    Polylang Version 2.7.4 by WP SYNTEX
    Post Slider by 10Web Version 1.0.59 by 10Web
    Recent Posts Widget With Thumbnails Version 6.7.0 by Martin Stehle
    SF Author Url Control Version 1.2 by Grégory Viguier
    SiteOrigin Widgets Bundle Version 1.17.3 by SiteOrigin
    Sucuri Security – Auditing, Malware Scanner and Hardening Version 1.8.24 by Sucuri Inc.
    Sydney Toolbox Version 1.11 by aThemes
    User Profile Picture Version 2.3.11 by Ronald Huereca
    WF Cookie Consent Version 1.1.4 by wunderfarm
    Wolf Redirect Version 1.0.4 by WolfThemes
    Wordfence Security Version 7.4.9 by Wordfence
    Workbox Video from Vimeo & Youtube Plugin. Version 3.2.2 by Workbox Inc.
    WP Links Page Version 4.5.4 by Robert Macchi
    Yoast SEO Version 14.6.1 by Team Yoast

    Thanks for being of service
    OC

    Plugin Author tech2serve

    (@tech2serve)

    Hmmmm. Nothing obvious jumping out at me. Two simple things you can try are to go into the Settings–>Permalinks page, and simply re-save those settings. Sometimes that resets how WordPress accesses the database, although usually that is with 404 errors.

    Another simple step you can try is to deactivate and reactivate the plugin and see if that clears up things.

    Let me know after that?

    Thread Starter Oclair

    (@oclair)

    Thanks for the suggestion, I disabled the plugin, re-enabled it, went to settings -> permalinks saved em and went from 404 to no results, meetings shows Screen-Shot-2020-07-30-at-16-28-57

    Plugin Author tech2serve

    (@tech2serve)

    What PHP version are you using? Please ensure it is 5.6 or newer.

    If you have access, please enable WP_DEBUG in wp-config.php and let’s see if you get a PHP error on your screen when you try to load the meetings page.

    Thread Starter Oclair

    (@oclair)

    Hi there,

    PHP 7.3.20

    I have debug now activated via
    define('WP_DEBUG', true);

    I even edited php.ini with
    display_errors = On

    Unfortunately the meetings archive remains empty without any error displayed
    Screen-Shot-2020-08-02-at-12-33-45

    Plugin Author tech2serve

    (@tech2serve)

    I’m not seeing any obvious errors, but I am seeing some things that confuse me so I’m going to engage the more experienced devs.

    You seem to be getting an empty data set back for jQuery request, yet individual meeting data is loading.

    In the meantime, if you have access to MySQL or its logs, perhaps you can look in those and see if anything jumps out?

    • This reply was modified 8 months, 3 weeks ago by tech2serve.
    Plugin Author tech2serve

    (@tech2serve)

    @oclair,

    What happens if you go into a couple of meetings (backend/admin side) and republish them? Do they then start showing up in the list?

    Thread Starter Oclair

    (@oclair)

    @tech2serve I am very sorry for the delay in responding. I have been updating wordpress/plugins/theme regularly but no change yet in behavior.

    I have edited meetings and even pending reviewed a few and then published them again. I have a feeling there is something from one of the meetings, or possibly there might be some new issue now with polylang and the meeting list page? Perhaps Polylang made the change, I am not quite sure.

    Maybe someone is running polylang as well out there?

    Thanks again for your service and have a nice evening,
    Oclair

    Thread Starter Oclair

    (@oclair)

    I thought maybe to ask if it might be possible to somehow export the database table for 12step meetings and completely rebuild the dataset to determine if this is some sort of conflict with plugins or simply something went south with the table’s data?

    Thread Starter Oclair

    (@oclair)

    I think I see something a little odd, It displays a language instead of the Region in the Region column, which indicates for some reason there might be an issue with Polylang being active on the site.

    https://hera.iolcus.net/s/meP8cnHs3gJjPRL

    Thread Starter Oclair

    (@oclair)

    I am unable to discern where the meeting list data is being written into on the database looking at the mysql tables.

    Thread Starter Oclair

    (@oclair)

    So I can pretty much confirm either a change possibly a wordpress update in Polylang or the Meeting List plugin has ment that the Region column now shows the page language when saving or creating a new meeting.

    Screenshot-2020-10-24-163452

    Screenshot-2020-10-24-163434

    For the moment I have been able to get the display working again with this bug.
    Basically the Meeting List Plugin appears to NOT have it’s own dedicated table in the Database as well. So hopefully at some point there will be a cleanup on the implementation. At the moment things work but it’s not yet set right.

    Thank you for your service,
    Oclair

    Thread Starter Oclair

    (@oclair)

    I created a support request in the Polylang support forum for this issue, As on another website I use Polylang pro their developer has in the past been very helpful getting incompatibilities with other plugins resolved.

    https://wordpress.org/support/?post_type=topic&p=13627203

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.