Support » Plugin: WP Full Stripe Free » TSL 1.0

  • Resolved cwilhelm

    (@cwilhelm)


    Hello

    I installed the WP Full Stripe plugin and when I click the pay button I get
    “Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at https://stripe.com/blog/upgrading-tls.”

    I attempted to remove all protocols and only included TSLv1.2 and I still get the error. Do you have any insight into this issue?

    Thanks!

    Curt

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter cwilhelm

    (@cwilhelm)

    I believe I found the problem, but I haven’t been able to test. Apache is version 2.2.15, which doesn’t support TLSv1.2 or SHA2.

    Plugin Author Mammothology

    (@mammothology)

    Hello Curt,

    There are two things that can cause Stripe to return the “Stripe no longer supports API requests made with TLS 1.0 …” error:
    – The Stripe PHP client of the plugin is too old
    – The operating system or the webserver is not configured to support TLS v1.2

    In the case of WP Full Stripe Free v1.5.x, the Stripe PHP client is reasonably up-to-date, and it has support for TLS v1.2.

    So in your case it’s most probably an issue with TLS v1.2 support at the operating system or webserver level.

    cheers,
    Csaba

    Plugin Author Mammothology

    (@mammothology)

    Hello Curt,

    I’m happy that you’ve managed to resolve the issue.

    I’m settings this topic to resolved now.

    cheers,
    Csaba

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘TSL 1.0’ is closed to new replies.