Support » Plugin: Jetpack by » Trying to use Publicize function, cannot add FB connection; logs me out

  • Resolved jasonpaulweber


    When I try to use the Publicize option, it logs me out and redirects me to the login screen. My WP version is 3.5 and the Jetpack came with my host’s 1-click setup — the current version of Jetpack – 2.1.1.

    Specifically, when I click “Add a new Facebook connection”, this is when I’m logged out and redirected to the login screen.

    Should I try deleting and then installing Jetpack again, or is this a known bug I can do something about?

    Thanks a bunch for your help!

    jasonpaulweber – at – gmail . com

    The blog I need help with is

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Jeremy Herve


    I had a look at your site, and everything seems to be working properly now. Jetpack Publicize is properly connected to your Facebook account.

    Could you let me know how you managed to solve this issue?

    Hi Jeremy. I didn’t mark this as resolved — unless I did it when I was super tired late at night and don’t remember … lol … Well, all Jetpack functions work except for the Publicize one. Whenever I post an issue on any forum … if I find a resolution, I’ll post it for posterity in case others have similar issues.

    The site I’m working on now started as a little Facebook blog, but now has tens of thousands of followers. And FB is connected to Twitter. So all I really wanted was the ability to connect to Facebook. But I’d like to get Jetpack working so I could connect to other Social Media sites like Google +, YouTube, and others, now that I’m making a site.

    I did get the ability to publish to Facebook working, however. Although the plugin is old and not updated, I got it to work after adjusting it. I did 2 things:

    1. I downloaded this plugin:
    2. After installing the plugin, it didn’t work right away. I went to Appearance > Plugins.
    3. Find the Post-to-Facebook plugin you just installed.
    4. Click Edit.
    5. Find the two (2) instances of “Facebok“.
    6. Just add the extra “o” in there, so it’s “Facebook“.
    7. Save.

    After doing this, a “Publish to Facebook” button appeared in my posts, and worked fine once I allowed popups from Firefox … so the Facebook thing could pop up. And of course, post to your FB page and choose your page, don’t just post to your timeline.

    Hope this helps in some regard … but still haven’t gotten Jetpack Publicize to work, although I’d like to!


    Plugin Author Jeremy Herve


    I had another look at your site, and Publicize is still connected to your Facebook account, and some of your recent posts were publicized properly:

    Did you experience problems with another site of yours, maybe?

    Jeremy — I’m an SEO guy new to WordPress. I know things have been posted on my timeline and I’m befuddled! I’ve tried to figure out how, but I can’t seem to find any setting. Take a peek at my Jetpack Publicize settings.

    If I did set up a FB share thing, I surely don’t know where to find it. I’ve looked in all of my WP settings.

    This is my first WP site, although I have a couple more domains to do once I’m more familiar with it, so I haven’t experienced any other issues on another site.

    I see you surely know what you’re doing! I love the Facebook likes on your page where thumbnails of their FB pictures show up — that’s cool, professional!

    Anyway, thanks for your help Jeremy … I really do appreciate you taking the time to try to figure out what I’m doing wrong.


    Plugin Author Jeremy Herve


    Thanks for the screenshots, it helps.

    Do you have any other accounts you use on that site? You might have created the Facebook connection through another WordPress account, and that would explain why it doesn’t appear in your sharing settings.

    I have the same problem. Trying to set up a Facebook connection, and every time I click the “Add new Facebook connection” it logs me out.


    My solution was to use a different plugin, although for some reason, my Jetpack works now.

    You have to do two options. The first is the Mailchimp Social Broadcasting option; it’s more modern.

    Or you can just use this dinosaur plugin: but you have to do two things:

    • It works. But you have to go to your plugins in your admin, and underneath the plugin, click edit. Edit the file and replace the two instances of “Facebok” with “Facebook”
    • After you publish your post, then you’ll click the Post to Facebook button manually … it’s not good if you’re wanting everything to be posted automatically. It’s good in that you have more control; you can always go back and post old posts to Facebook … and if you don’t want something posted, you don’t have to.

    But somehow, the Jetpack started working again — through nothing that I consciously did … I’m always testing plugins and deleting deactivated plugins, so maybe there was a conflict there and I deactivated the conflicting plugin. I’ve had issues with Jetpack conflicts with a few things … so that was probably it. But I deleted the dinosaur plugin and am just using the Social Broadcasting one.

    Un Mo


    Hi …

    im trying to authorize a new twitter connection, it redirects me to twitter, and once i click on autorizhe this app my wordpress logs me out … i cant connect it

    This is happenning in one of my sites, the other 2 sites i connected with no problems

    anyone can help me pls ?

    tnx in advance

    Plugin Author Jeremy Herve


    Could you create a new thread about your issue, and let us know your site URL so we can have a look at the problem?

    If you want your site to remain private, you can also contact us via this contact form:

    Thank you.

    I’m now also having the same issue, when i try to add any social network connection WP logs me out and redirects me to the login page again…

    Plugin Author Jeremy Herve


    @bearkiter Could you create a new thread about your problem, as I mentioned above. It would also help if you let us know your site URL in that new thread.


    Same thing here, when i try to add any social network connection it logs me out and redirects me to the login page again…
    my url is but it happens on 4 other sites on the server.
    the server has a nginx/php5-fpm config, if that’s relevant.

    Plugin Author Jeremy Herve


    @andrei Chira Could you please start your own thread, as per the Forum Welcome?

    Thank you!


    Hi guys!
    I am hoping you can help with this query about Publicize. I want to link to Facebook and LinkedIn.

    It works fine for Twitter (even though I don;’t want that link)

    Can you help?

    Thanks in advance

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Trying to use Publicize function, cannot add FB connection; logs me out’ is closed to new replies.