Support » Plugin: LiteSpeed Cache » Trying to use JS Delayed option

  • Hello,

    I’m trying to activate the JS Delayed option (not Deferred option) and it’s breaking images on my website (both WP core images and Galleries)

    I’ve found that there was a conflict with 2 plugins :

    – When JS Delayed is ON then WP core images are broken. And if I deactivated the plugin EWWW Image Optimizer, images are displaying.

    – When JS Delayed is ON then image galeries using Meow Gallery plugin are broken. And if I deactivated the plugin Meow Gallery, images are displaying well in WP core gallery.

    – Off course, if I don’t use JS delayed option, everything works fine with Bothe plugins activated.

    How can I resolve this issue and be able to use LS cache JS Delayed option with these two plugins ?

    Thanks !

    PS : JS Deferred is working fine and not causing any issue but performances results are not as good as when I use JS Delayed (High Total Blocking Time I want to kill)

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • There is no delay setting in cache plugin, but only a function for deferred loading scripts. Defer == Delay, so what exactly do you mean?

    Thread Starter samlaflam

    (@samlaflam)

    I’m talking about this option : https://imgur.com/q4DNOw6

    In Page optimization > JS settings > Load JS Deferred.

    There is three options here : OFF / Deferred / Delayed.

    So I’m talking about the Delayed option.

    Okay, now I know what you mean. Sorry for missunderstanding.

    As you can read the hint to this setting

    This option may result in a JS error or layout issue on frontend pages with certain themes/plugins.

    it is no doubt, that you get an error if other plugins needs fo example jQuery Framework when page is loaded. The delayed setting loads scripts first after user action. This is maybe too late for the functions of other plugins, but this might be the reason for your issues. So you can’t use delayed setting. You could have found out this information yourself if you had called up the linked note.

    https://docs.litespeedtech.com/lscache/lscwp/pageopt/#load-js-deferred

    Thread Starter samlaflam

    (@samlaflam)

    Thank you for your reply,

    I know that this option is causing issues.

    I was asking if there would be a solution to resolve this issue, go around the conflict, like the type of question I could ask to a support forum.

    But you’re right, that was a really stupid question. My bad.

    There are no stupid questions, only stupid answers! šŸ™‚

    The delay function in cache plugin is not bad, but has a high risk that something goes wrong if other plugins need Javascript for building the layout or for any function in theme. I have currently no idea how to help you, but maybe plugin support has any ideas to solve it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.