WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Trying to translate button texts – does not work

[Resolved] Trying to translate button texts – does not work

Viewing 10 replies - 1 through 10 (of 10 total)
  • I get this error message:

    Error: Gettext msgfmt exited with code 127; Got 0 bytes from 4014 bytes

    This is because I do not have access to the msgfmt command. And I will not get access to it, either. 🙂

    So, is there any work-around for this? Perhaps install a Swedish PO-file from somewhere?

    Plugin Author timwhitlock

    @timwhitlock

    The next version will have a fallback for MO compilation. I will update this issue when this is available.

    In the mean time you can use one of the following to create MO files from your PO files, because they should still have saved OK:

    https://localise.biz/free/poedit

    https://localise.biz/free/converter/api#to-po

    Alright, I try this. But where can I find my PO file?

    I guess that I drop it on the on-line translator and save the MO file in the same directory as the PO file?

    Plugin Author timwhitlock

    @timwhitlock

    If it says “OK: PO file saved – videoblog-xx_XX.po” or something similar it should have saved it somewhere under the plugin directory, assuming you have made it writable by the web server.

    So, now I have the richwp.po and the richwp.mo in the same directory. Do I need to empty cache or something, because I still cannot see any changes?

    Plugin Author timwhitlock

    @timwhitlock

    I can only help with the generation of PO and MO files, because that’s all the plugin does I’m afraid.

    I’m not aware of any caching when loading text domains.

    Plugin Author timwhitlock

    @timwhitlock

    The current development version (1.3.2) now includes a native MO compiler that does not have a Gettext msgfmt dependency.

    http://wordpress.org/plugins/loco-translate/developers/

    The built-in compiler is the default unless you’ve already set a msgfmt path. Visit the Settings tab to change which compiler is used.

    Please let me know if I can close this issue.

    Plugin Author timwhitlock

    @timwhitlock

    Native MO compiler is built into stable version 1.4.

    Hi Tim!
    I have installed the Loco 1.41 and my changes in the language file is there. But when I save and get a green bar telling me that MO and PO is compiled, I cannot see my translation on the website.

    I must be missing something – but what?

    Niklas

    Plugin Author timwhitlock

    @timwhitlock

    Loco’s job ends at compilation of the MO file. It can’t help you set up your theme or plugin correctly to use it.

    If you email the MO file to [ support at localise dot biz ] I can tell you if the MO file is corrupt.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Trying to translate button texts – does not work’ is closed to new replies.