Support » Fixing WordPress » Trying to track down an 'error'

  • Okay…uploaded time #3. Got all the files off the queue, apparently into their places on the server. Nothing leftover and “sitting.” However, upon trying to log in, I get another Parse Error. I tracked it down in NotePadPlus which gives enumerated lines (kudos to NPP). The trouble seems to be this-

    syntax error, unexpected $end

    When I found that particular line, I didn’t see anything at all wrong with it. I see a lot of $pung kind of things on that file.

    Any thoughts, anyone? Maybe I could re-upload just that *one* file in hopes it would behave itself?

    I could even paste the file contents into pastebin (if someone would kindly direct me how to remove my ID from there)?

Viewing 11 replies - 1 through 11 (of 11 total)
  • errors in what file? is this when you are trying to install WordPress?

    Oh, sorry, Rich!!! Forgot to tell exactly which file it is that has the Error. It’s “post.php” and it resides in…let me see….here it is:

    wordpress/wp-includes/post.php on line 2754

    Like I said, I tracked down that line, and couldn’t see anything wrong with it. Unless it’s something really uber-technical that I can’t decipher.

    But, currently, this error is preventing me from logging in at all… I uploaded my Version 3 several times to be sure all files got uploaded, nothing sitting on the queue. I was getting parse errors even though I was able to log in. And now, this syntax error (see my earlier post) turns up out of nowhere. What gets me is, why?

    Is this a fresh install?

    I would assume not, and suggest you delete all your plugins and try again. then re-add them one at a time until you find the culprit.

    But first.. which web host are you using?

    Actually it’s a domain owned by a friend…I don’t know if it’s GoDaddy or what it might be. But I will ask her.

    And No…I wouldn’t call this a fresh install…since I’ve done it 3 times now. And to be honest, at first I hit “the wrong button” and auto-updated. Maybe I would have been better off leaving that, and not tried to manually install?

    I had 2.9.2 before that, and it was fine till suddenly I was not able to preview or save posts any longer…for some totally mystifying reason (which has been discussed elsewhere, and from what I see, others are having very similar problems). I was hopeful that the upgrade would clear up the issues…but, nope!! Things are getting worse instead of better.

    Also, from what I’ve been reading on the forums, plugins can do/cause some weird things. I only have 1 that I recall (aside from Akismet), that being the administrators’ widget that makes the tabs appear along the tops of all pages (like it does on dot Com).

    So, deleting my plugins won’t take long! 🙂

    [Four minutes later] Done! Deleted the admin-bar plugin, tried the login again….and sadly, I’m still getting this:

    Parse error: syntax error, unexpected $end in /home/seaymee/public_html/aeolusia/wordpress/wp-includes/post.php on line 2754

    Try re-uploading the wp-admin and wp-includes folders from a fresh download of your current version of WordPress.

    OK, I’ll delete the other one…and re-do. This will be, what, the fifth time…? I’ve lost track…lol

    I even wondered about re-uploading just the “post.php” file…

    If one of the files in wp-includes has been damaged, it’s likely that others will have been affected too.

    I am on dialup, and there has been strangeness in my FTP, so it is just possible that something in wp-includes was messed up during uploading. Downloading the zipfile and unzipping seem to go fairly quickly even on dialup, though. Takes way more than 5 minutes, but still not too bad for my slow connection 😉

    Oh my! Now we have a different Parse error!

    “…expecting ‘(‘…” I bet I could fix that! Dare I try?

    Parse error: syntax error, unexpected $end, expecting ‘(‘ in /home/seaymee/public_html/aeolusia/wordpress/wp-includes/formatting.php on line 2223

    OK, here is what I find on that file on lines 2220 through 2224; does this look ‘normal’? Or should that ( be between the two single quotation marks? Splitting hairs, I know, but…

    function esc_url( $url, $protocols = null, $_context = ‘display’ ) {
    $original_url = $url;

    if ( ” == $url )

    yes it looks correct.

    It does sound more and more like things are being FTP’ed correctly. Dial up could cause a few issues theses days, but it shouldn’t. Try an different FTP client perhaps?

    Then I better not mess around with it, huh? =\

    I finally found out two things from my friend who owns the domain: she did purchase her domain from GoDaddy, but her host is BlueCapacity. That doesn’t quite make sense to me, but, whatever.

    Sooo, okay… Currently I use (or have been using) FileZilla. Back when I had a smaller system and used Windows 98, I was able to FTP via Explorer with decent results. I wish I could do that now, but I’m not sure. I’ve looked at other online FTP services but I’d have to be very careful about uploading limitations. I see that wp-includes is 4.40 MB and wp-admin is 2.68 MB. I have a new Firefox add-on, a type of FTP, but I don’t know whether it has any strict uploading limits.

    My pal still says the trouble is on my end, not hers, she can get into my site just fine! At this point I would not be surprised if my goofy dialup is the culprit.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Trying to track down an 'error'’ is closed to new replies.