Support » Plugin: AMP » trying to save “Transitional Template Mode” creating error.

  • Resolved buzibuzi

    (@buzibuzi)


    Hi,
    In “AMP Settings” when trying to trying to save as “Transitional Template Mode”, im getting this error.

    
    TypeError: Cannot read properties of undefined (reading 'query_var')
        at u (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:40:1567)
        at ni (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:74335)
        at Bi (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:83853)
        at Bc (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:127711)
        at gs (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:113750)
        at Ls (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:113678)
        at hs (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:113541)
        at us (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:110528)
        at https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:60233
        at t.unstable_runWithPriority (https://www.example.com/wp-content/plugins/amp/assets/js/amp-settings.js?ver=85a69fcacdf45677e3559bda1801aabc:60:137428)
    
    • This topic was modified 2 years, 2 months ago by Yui.
    • This topic was modified 2 years, 2 months ago by Yui. Reason: formatting
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Milind More

    (@milindmore22)

    Hello @buzibuzi

    Thank you for creating a support topic, can you please share your site URL along with site Health using this form privately. so we can further investigate the issue.

    Additionally, can you please disable all redirection rules applied (via plugin or server configuration) and recheck if that resolves your issue, a similar topic was previously created where they have enabled redirection for AMP pages to non-AMP pages.

    Hope this helps!

    Thread Starter buzibuzi

    (@buzibuzi)

    Thanks Milind, i sent the form.

    Plugin Support Milind More

    (@milindmore22)

    Hello @buzibuzi

    Thank you for the site info, we tested plugins that are freely available, one of the plugin on your site Ajax Upload for Gravity Forms is closed by its author, We will recommend finding an alternative to it also there are some plugins on your site that are premium and we don’t have access to those plugins so we will recommend self-diagnostic using the health and troubleshooting plugin.

    To narrow down further, could you use the Health Check & Troubleshooting plugin and enable its troubleshooting mode. This mode disables active plugins and switches to a default theme safely since it only affects the experience of the logged-in user.

    – Please enable the AMP plugin and let me know if the issue is present.
    – Enabling plugins and your theme one by one in this mode may help pinpoint if something else is involved.
    – Note you can disable troubleshooting mode from the plugins page.

    Hope this helps!

    Thread Starter buzibuzi

    (@buzibuzi)

    Thank you Milind. it seems some plugin or theme is causing this. i will keep investigating

    Plugin Support Milind More

    (@milindmore22)

    @buzibuzi just checking if you are able to find the culprit?

    Thread Starter buzibuzi

    (@buzibuzi)

    Hi Milind, thanks for your follow-up. im dropping this for now. will get back to it later

    Plugin Support Milind More

    (@milindmore22)

    ok I’ll mark this as resolved Open a new support topic if you face further issues.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘trying to save “Transitional Template Mode” creating error.’ is closed to new replies.