WordPress.org

Ready to get started?Download WordPress

Forums

Trying to run install script and it downloads file (8 posts)

  1. jimbolad
    Member
    Posted 1 year ago #

    Okay so I am trying a fresh install of wordpress on a clients site.
    Ive uploaded the files on the the server using FTP ( filezilla), and edited the wp-config.php file matching the new databsase settings aswell. Now the next step is to run the install script I believe but when I type the url in ( mysite.co.uk/wp-admin/install.php ) it downloads the install.php file.

    Im thinking that im seeing a directory listing rather than a web page which is why it is downloading the file i type in the URL. Now I think it is an issue regarding .htacces but I do not know how to create it nor what to put in it in order to point to the index.php by default and ?

    Any ideas thanks?

  2. Tara
    Member
    Posted 1 year ago #

    site url?

  3. jimbolad
    Member
    Posted 1 year ago #

    unfortunately the site isnt live yet so I've had to change my host file in order to view the development so the URL wouldnt work?

  4. Tara
    Member
    Posted 1 year ago #

    Im thinking that im seeing a directory listing

    If I understand it correctly, try adding:
    DirectoryIndex index.php index.html index.htm to the top of an .htaccess file in the blog subfolder.

    regarding .htacces but I do not know how to create it

    you can find a lot of examples and tutorials online.

    related: http://wordpress.org/support/topic/how-to-create-htaccess-files?replies=3

  5. jimbolad
    Member
    Posted 1 year ago #

    Thankyou for quick replies but onfortunately I've tried this and nothing changes. Very weird because I've installed wordpress plenty of times and never come accross this...

  6. Tara
    Member
    Posted 1 year ago #

    Have you contacted your webhosting? They may shed some light!

  7. jimbolad
    Member
    Posted 1 year ago #

    Yea just got reply and it worked :)

    For any one that has this problem in future ,

    I had to turn on something called PHP Module or PHP Support in my Hosting settings.

    Phew

    cheers @Tara

  8. Tara
    Member
    Posted 1 year ago #

    Glad you got it resolved :-)

Topic Closed

This topic has been closed to new replies.

About this Topic