Support » Fixing WordPress » Trying to make blog posts post to both a category and a specific page

  • kellydotgov

    (@kellydotgov)


    Hello –
    So far in posting a test blog I am able to get it to connect with a category, but for some reason I cannot get it to ALSO post on a specific page from my main nav menu at the top (sportsbykelly.com). I must be overlooking something, can someone please point me in the correct direction?

Viewing 15 replies - 1 through 15 (of 28 total)
  • panther8

    (@panther8)

    Hi Kelly, you would have to install the Category Page Plugin to associate a blog entry with one of your pages.
    http://wordpress.org/extend/plugins/page2cat/

    kellydotgov

    (@kellydotgov)

    Thank you so much for the link. I have installed this plug in, but it does say something about having to edit the archive.php in order to make it work properly… which I am now having trouble locating and doing.
    I’m using the Suffusion theme

    dremeda

    (@dremeda)

    Hi Kelly,

    Not all themes include an archive.php

    In case you need to create one, check out Creating_an_Archive_Index.

    Cheers!

    kellydotgov

    (@kellydotgov)

    Thanks dremeda, I have tried using that link, but all the info is for using WP v1.5.. Figuring this out via 3.0.1. is a bit different?

    dremeda

    (@dremeda)

    Same thing applies for 3.x.x

    An easy way to get a current archive.php into your theme is to copy the one from the Twenty Ten theme. It should work just fine 😀

    kellydotgov

    (@kellydotgov)

    OK. I have the archive.php installed.
    There is another step to this to get it to work.. I should need to tweek the content, yes? It isn’t working as is.

    kellydotgov

    (@kellydotgov)

    I still cannot get my categories linked to my different pages. anyone have any other helpful insight?

    dremeda

    (@dremeda)

    Hi Kelly, can you give the default Twenty Ten theme a shot to see if everyone connects correctly?

    The theme you’re are using may be causing the issue.

    kellydotgov

    (@kellydotgov)

    No, it is not working on the twenty ten, either.

    dremeda

    (@dremeda)

    OK. Lets start here.

    Enable Permalinks

    Try using /%postname%/ for now, will make it easier to navigate with pretty links. 🙂

    Go to Settings/Permalinks.

    Then, are you using the WordPress menu’s? Or did you hard code the pages?

    Something in your navigation seems off.

    When I click the NFL category in your right sidebar, it pulls up the category page correctly: http://sportsbykelly.com/?cat=13

    If you look at it in the main top nav, NFL is in a drop-down under football and is linked to http://sportsbykelly.com/?page_id=21 which is not correct of course.

    kellydotgov

    (@kellydotgov)

    I am using the WordPress menu… Coding is definitely not up my alley 🙂
    I am in the settings/permalinks

    am I going to be using the common setting or optional settings?

    dremeda

    (@dremeda)

    No worries, will try to assist as much as possible.

    In the common settings use a custom structure and add /%postname%/ in the field.

    kellydotgov

    (@kellydotgov)

    so just http://SportsByKelly.com/%postname%/ ?
    Sorry, first timer!

    dremeda

    (@dremeda)

    Just add /%postname%/

    kellydotgov

    (@kellydotgov)

    Done.. That doesn’t seem to fix the problem, yet.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Trying to make blog posts post to both a category and a specific page’ is closed to new replies.