trying to install wp (4 posts)

  1. dividedplaces
    Posted 9 years ago #

    this is my latest error:

    Parse error: syntax error, unexpected T_STRING in /data/members/free/tripod/uk/d/e/v/devided/htdocs/wordpress/wp-config.php on line 5

    this is my wp-config.php file:

    // ** MySQL settings ** //
    define('DB_NAME', ' DividedPlaces_uk_db'); // The name of the database
    define('DB_USER', 'DividedPlaces'); // Your MySQL username
    define('DB_PASSWORD', 'passwordhere'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');//
    define('DB_COLLATE', '');//

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');

    before this error i got could not find data bases..here is my information:

    Your dateabase information
    Name: DividedPlaces_uk_db
    Username: DividedPlaces
    Password: no password needed
    Host: localhost
    FTP settings

    FTP address:ftp.members.lycos.co.uk

  2. dividedplaces
    Posted 9 years ago #

  3. mrmist
    Forum Janitor
    Posted 9 years ago #

    have you got a quote mark in your password?

    I really can't see where the error is, unless it's that. The error suggests that you're missing a ' mark somewhere, but I can't see any missing.

  4. whooami
    Posted 9 years ago #


    if you REALLY dont need a password, you might TRY this ..

    1. remove this line completely from wp-config.php:

    define('DB_PASSWORD', 'passwordhere'); // ...and password

    then, open up wp-includes/wp-db.php and locate THIS line:

    $wpdb = new wpdb(DB_USER, DB_PASSWORD, DB_NAME, DB_HOST);

    and change that line to read:

    $wpdb = new wpdb(DB_USER, DB_NAME, DB_HOST);

    you should know though, that I have NOT tested that, it might work, might not, AND that it is VERY insecure (if it works at all).

Topic Closed

This topic has been closed to new replies.

About this Topic