W3 Total Cache
Trying to install W3TC generates fatal error (7 posts)

  1. databell96
    Posted 3 years ago #

    I'm trying to install W3TC for the following site hosted by web.com. Go to install it and I get a fatal error message as follows:

    Fatal error: Call to undefined function w3tc_button_link() in /home/cluster1/data/q/t/706391/html/2011/wp-content/plugins/w3-total-cache/lib/W3/GenericAdminEnvironment.php on line 99

    What exactly is that and why is it occurring? I've installed W3TC before on other sites and never experienced this


  2. rbmark
    Posted 2 years ago #

    I have the same problem.

  3. michaelgs
    Posted 2 years ago #

    I too have this problem and cannot activate w3 total cache

  4. Sergey Biryukov
    WordPress Dev
    Posted 2 years ago #

    See Thomas van der Beek's reply on Fatal error: Call to undefined function w3tc_button_link(), it worked for me.

  5. rbmark
    Posted 2 years ago #

    I tried, but none of the solutions listed here work.

    Any other ideas?

  6. bobk88
    Posted 2 years ago #

    If you have any other caching plugins installed but inactive, try deleting them.

    I got a fatal error message (might have been a different one) when I first tried to install W3 Total Cache.

    Then I realized that while I had inactivated WP Super Cache (another caching plugin), I had not deleted it.

    After deleting WPSC, I was able to install W3 Total Cache without incident.

    Hope this helps.

  7. rbmark
    Posted 2 years ago #

    I've tried all the suggestions, including deleting all other cache plugins. Thanks though. I've pretty much given up on W3TC.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic