WordPress.org

Support

Support » How-To and Troubleshooting » Trying to go live

Trying to go live

  • OsakaWebbie

    @osakawebbie

    After getting a WP site running in a subdirectory (/wordpress/), I now want to use .htaccess to point the subdomain root to it, but it isn’t working. I tried to follow this tutorial, but it seems to have made things go the opposite way from intended!
    The .htaccess as it stands now, says:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    # END WordPress

    http://japan.deafmin.org still goes to the old site, even if I manually specify index.php (which I copied per the instructions; my old site is index.html). And http://japan.deafmin.org/wordpress no longer works either – I get either a 404 error or one of the old site pages if the path happens to line up. Can someone see what I did wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • OsakaWebbie

    @osakawebbie

    Or, do you recommend that I just move the whole thing to the root directory to avoid the issue altogether?

    I’m not familiar with the syntax of .htaccess and can’t find any web pages that actually explain what the lines mean (the pages just say “do this”), so I don’t know how to fix it (or why it isn’t working in the first place, since I just followed the instructions). In fact, I can’t even find a page that shows what the .htaccess content is expected to be – the afore-mentioned doc page just says to copy the file and trust that WP created it with the right stuff. In case it’s relevant, my Permalinks setting (which worked in the subdirectory before I tried to do the redirect) is:
    Custom Structure: /%category%/%postname%/

    OsakaWebbie

    @osakawebbie

    Never mind. I really needed this site live this week, because it was announcing events happening this weekend – after waiting a couple days for help on this thread, I decided I needed to do something. So I moved everything to the root according to these directions. I guess we will never know what the problem was…

    carrierawks

    @carrierawks

    The .htaccess file should have looked something like this to have it point to the right area:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Trying to go live’ is closed to new replies.