Support » Networking WordPress » Trying to get network setup – subdirectories not working

  • I have set up WPMU and 3.0 network sites fine in the past, but this situation has me a bit puzzled.

    Originally wanted to set it up as subdomains, but that wasn’t possible, as I don’t have access to cpanel or other admin privileges, so opted for subdirectories.

    Main site works fine.

    .htaccess file in place (correct base directory is set)

    When I create a test user and test site, I try to view the test user’s site and get a 404 error.

    I’ve double-checked config files and .htaccess file according to what is in the network setup page.

    Where else should I be looking for an error? What else could be wrong?

    Thanks in advance!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same exact problem, tried messing with the CHARSET and COLLATION but no luck.

    Created fresh install, converted to multisite, created new site and still get same behavior: 404.

    Thanks!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Remember the .htaccess file is read via mod_rewrite. make sure it;s actually reading the htaccess file.

    How can we verify that it is being read? I have the same problem. Is the mod_rewrite available for changes on a shared host?

    Thanks

    Ask your host is mod_rewrite is turned on for your account. Generally it is but sometimes they forget to make a settings change.

    Just checked with my webhost (DreamHost) & they said that mod_rewrite is turned on by default for all sites. I also have WP installed on a IIS system & have the same problem, 404 errors.

    Tech support said my .htaccess file has some funny stuff in it. What I put in there is what the installer instructions said to put there. Can anyone tell me what EXACTLY should be in there???

    I am having the same problem on DreamHost with my sub-directories not working.

    Main site is working fine, but any network sites I create get the following error message.

    “Not Found” “Apologies, but the page you requested could not be found. Perhaps searching will help.”

    My .htaccess file has only what the installer instructions said to put there.

    DreamHost says Mod_Rewrite is turned on. Does my .htaccess file look o.k.? I posted it below

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Trying to get network setup – subdirectories not working’ is closed to new replies.