WordPress.org

Forums

WordPress HTTPS (SSL)
Trying to deactivate. Can access admin except plugins page (4 posts)

  1. Alusza
    Member
    Posted 1 year ago #

    Can't get to the plugins page after a struggle to remove wordpress-https plugin.

    I get redirected to https://domain.com/wp-admin/plugins.php, though the install is on http://subdomain.domain.com/ . I need to remove that redirect somehow.

    I was pretty dumb...I do have SSL, but I was dumb because I've temporarily put the site on a subdomain and SSL cert won't work on subdomain anyway.

    Tried uncommenting the reset line as per support instructions and then hitting a page then recommenting the line. No go. I can go do any other part of admin, just not plugins.

    I tried renaming the wordpress-https plugin directory to disable it. Didn't work.
    I tried deleting all plugin values from database. Didn't work... so did reset again. Values are back in db but still locked out of plugins page.

    Wondering if anyone one smarter than I (and that's truck loads of folks) has any ideas what I might do?

    Thanks.

    https://wordpress.org/plugins/wordpress-https/

  2. askwpgirl
    Member
    Posted 11 months ago #

    I am having the same issue after migrating to a new domain and all the tips including this one:

    http://wordpress.org/support/topic/https-force-admin-ssl-breaks-admin-how-do-i-disable

    Have not worked for me. Have you had any luck yet?

  3. askwpgirl
    Member
    Posted 11 months ago #

    Okay, I got it to work.

    You need to add this line to your wp-config.php file

    define('WPHTTPS_RESET', true);

    Visit any page on the front part of the site.

    Then, delete that line.

    The problem I had was that Firefox (and other browsers) CACHES Redirects, so while this worked, I didn't think it worked because the browser had cached the redirect. Logging in another browser worked, so you will need to completely delete your current browser's cached files and perhaps restart the browser.

  4. Alusza
    Member
    Posted 11 months ago #

    Yes...this worked. Thank you! I had used the reset in wp-config but it didn't take. Couldn't figure out why. It was the caching. Thanks for that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic