Support » Fixing WordPress » Trying to change WP uplaod size limit

  • Hi,

    I am trying to change the upload size limit in WP 4.9.8. In the Dashboard (Media > add new) it shows 8 MB.

    Both the php.ini and .htaccess files have the code for 32 MB. Unless the code in wrong.

    PHP.INI looks like this:
    ———————-

    ; Maximum allowed size for uploaded files.
    ; http://php.net/upload-max-filesize
    upload_max_filesize = 32M

    ; Maximum number of files that can be uploaded via a single request
    max_file_uploads = 20

    ———————–

    .htaccess looks like this
    ———————–

    # END WordPress
    php_value upload_max_filesize 32M
    ———————–

    Also, when I’m logged in as Admin, I do not have “Editor” under Appearance.

    Were is this limit actually restricted. Where should i change it? Do I only need that setting once somewhere?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • In an attempt to help solve the upload issue first:

    post_max_size may need to be adjusted as well. I think it may need to be at least equal to the upload_max_filesize value. Some info that may help:

    File Upload Limit

    The maximum upload size is controlled at the server-level, not by WordPress. Here are three ways you can increase the upload limit:

    1. If you can edit or override the system php.ini file, increase the maximum file and post sizes. For example, upload_max_filesize = 100M ; and post_max_size = 100M ;

    2. If you cannot edit or override the system php.ini file, add php_value upload_max_filesize 100M and php_value post_max_size = 100M to your .htaccess file.

    3. If neither of these work, it’s time to ask your hosting provider to increase the maximum file and post sizes on your account. Keep in mind that most decent hosting providers allow this, and If your hosting provider won’t accommodate you, perhaps it’s time to find a new hosting provider.

    4. There are some plugins in the plugin directory that can help you get around this limit, for instance, helping you “chunk” your uploads, breaking them into smaller parts. Try searching “increase file upload limit”.

    (in the above examples, the limit is set to 100MB)

    Thanks for replying. Sorry it took a while to get back to you.

    I found the that post_max_size = 8M (which reflected the same size the the Dashboard editor showed). Which made sense and I thought I had it. So I changed it to 32M (same as upload_max_filesile = 32M)

    It DID NOT change in the Admin Dasboard (Media > Add new).

    Also, in php.ini, ;enable_post_data_reading = Off and it was disabled, so I enabled it and turned it to “On”. Nothing.

    Also edited that same things in the .htaccess file. Nothing.

    Q1: I noticed there were of php.ini file locations. I’m wondering if I have the right php.ini file. Where is the location of the one I need to edit?

    Q2: Do I need to restart/reboot anything to have these changes take place?

    What could I be doing wrong? The site is on a Linode Linux box w/ ubuntu.

    Thanks in advance for your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Trying to change WP uplaod size limit’ is closed to new replies.