Support » Networking WordPress » Trying to add a domain do my mulitisite network

  • Hi!
    Please help me to undertand
    Im trying to add a new domain to my wordpress multisite network.
    After i added a website to my main domain thru the adding site option(as a subdomain) i changed its url to the new domain, but it doesnt work. I get “This site can’t be reached
    ” when im trying to enter the new domain..
    what i did wrong? do i have to add and addon domain thru my cpanel?
    Thank you

    adikf

Viewing 5 replies - 1 through 5 (of 5 total)
  • Steve

    (@shifisteve)

    Yes if you are using cPanel you also need to add the domain in there so the server knows where to route requests. With cPanel you can either do this as an alias or as an addon domain (with addon domain you need to ensure the document root is the same as the primary WordPress domain).

    Thank you but it doesnt work, when you wrote
    “with addon domain you need to ensure the document root is the same as the primary WordPress domain” – Did you mean the new directory has to be inside the public_html right?

    alias – Do i need to redirect or just to make the alias?

    what i did
    1. Put the right dns address in my domain company account
    2. I made a new site in my multisite settings: MyOldMaindomain/MyNewSite
    3. I changes its URl to my new site: https://Mynewsite.com
    4. I made addon domain and after it doesnt work i tried alias, both didnt work
    what did i do wrong?

    Thank you it really was the document root

    This is clear as mud.

    I understand the first question, so let me just re-ask it with my own specifics, because I’m still having this trouble.

    First, I have added my new domain as an Add-on Domain in my cPanel. My new domain is janesorensen.com, and it’s pointed at public_html.

    So, I’m trying to add a new domain to my wordpress multisite network. My network is at bigcitylittlehomestead.ca
    After i added a website to my main domain thru the adding site option (as a subdomain)
    as it requires me to. I chose “janerette.bigcitylittlehomestead.ca”
    I’ve added two super admin users and connected Jetpack.

    IF I TRY TO change its url to the new domain, janesorensen.com, as either the Site Address and/or the settings for SiteURL or Home, IT NO LONGER WORKS. I can’t log in. I get a “Greetings, Network administrator!” under my bigcitylittlehomestead banner. OR, I get the WordPress.com login, but it rejects both of my Superuser logins, and tells me I need to have cookies enabled.

    So it’s forcing me to use janerette.bigcitylittlehomestead.ca but this is NOT ideal, I do not want to have to redirect the new domain I just bought to janerette.b…

    Moreover I already have a second site on my WPMU that has its URLs fully mapped/directed to their domain – it was not always this way, I used to have to login at <subdomain>.bigcitylittlehomestead.ca, but a few months ago it took the mapping without issue.

    Please help

    I had to get my shared host to work on and fix the problem.

    It worked for a full day

    And now I’m locked out of my network, with the exception of one browser that I dare not close

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Trying to add a domain do my mulitisite network’ is closed to new replies.