Support » Plugin: Plugin Organizer » Trying to access array offset on value of type null

  • HI, first of all thanks for the great plugin!

    I’m, however, having a problem with him.
    I simply activated “Selective Plugin loading” and set a filter disabling a couple plugins on the homepage. It works as expected 🙂

    But no matter what page I access, the Query Monitor plugin always flags a single PHP Error, and it’s coming from your plugin:
    Message: Trying to access array offset on value of type null – Location: wp-content/mu-plugins/PluginOrganizerMU.class.php:84

    How can I fix it?

    Thanks in advance!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok, the PHP error disappeared once I set global rules. That’s nice.

    The problem now is another…
    I have global rules disabling a plugin, because I want it Disabled for all posts.
    On top of that, I have filters set so that same plugin is Enabled in a category page.
    It works perfectly when I’m NOT logged in. The plugin is Enabled on the category page.
    However, if I’m logged in, only Global rules apply, and the plugin is Disabled on the category page. I can see that in the Debug: it only shows global rules.
    Even if I disable debug the problem persists: Filters are only applied to NON logged in users. It doesn’t matter if it’s Administrator or editor.

    Any suggestion on what I might be doing wrong or how to fix it?

    Thanks in advance!

    Ok, i changed everything, it works, but still:
    1. The Loaded plugins are different for logged in or non logged in. I didn’t set any role-related rules
    And also without any specific rule. When logged in, some plugins obey the rules, some don’t
    2. Still lots of PHP errors (lots)
    In your own settings page:
    Notice Undefined index: front_debug_style 1 +
    Plugin: plugin-organizer
    Notice Undefined index: admin_debug_style 1 +
    Plugin: plugin-organizer

    What’s going on?

    • This reply was modified 2 months, 3 weeks ago by wagedu.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.