Support » Plugin: Memphis Documents Library » Try to avoid using !important

  • Hi. Please, try to avoid using in CSS !important because this restrict us to customize design for our theme. Examples:

    #mdocs-list-table .mdocs-desc {
        width: 15%!important;
    }
    #mdocs-list-table .mdocs-version {
        width: 9%!important;
    }

    Why u need here !important?

    Other bug. Dropdown Go publication link icon broken, because free version has solid style only, but u trying to use regular that comes with Pro version fontawesome. U need to change
    <i class="far fa-arrow-circle-right" aria-hidden="true"></i>
    to
    <i class="fas fa-arrow-circle-right" aria-hidden="true"></i>
    Source – https://fontawesome.com/icons/arrow-circle-right?style=solid

    Or u can replace this icon with other regular style icon – https://fontawesome.com/icons/arrow-alt-circle-right?style=regular

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author bhaldie

    (@bhaldie)

    thanks, will update the font awesome link in the next version.

    Thread Starter Ivaseg

    (@ivaseg)

    Still not fixed CSS issue.

    /wp-content/plugins/memphis-documents-library/memphis-documents.min.css

    .mdocs-desc{vertical-align:top;margin:15px 0!important;padding:0 0!important;border-top:solid 1px #d1e5ee;color:#333;width:75%!important}
    #mdocs-list-table .mdocs-desc{width:15%!important}
    Why you use rule !important twice for the same class? Please, remove them both for width property, it’s not required at all and this is restrict us to use own style settings to display.

    Another one:
    #mdocs-list-table .mdocs-version{width:9%!important}
    replace to
    #mdocs-list-table .mdocs-version{width:9%}

    Man, I’m really don’t know why you use rule !important here. We can’t rewrite this settings as additional theme CSS while you using rule !important. It was ok in previous versions, but now you broke theme settings with this rule !important that not needed here at all.

    • This reply was modified 2 years, 9 months ago by Ivaseg.
    Thread Starter Ivaseg

    (@ivaseg)

    Ok. Again and again each new version brokes table styling. So, I tested and want to ask you to remove all width value for 3 columns. And then each user can style table as he want in his theme CSS.

    Path: /wp-content/plugins/memphis-documents-library/memphis-documents.min.css
    Remove this:

    #mdocs-list-table .mdocs-title {
        width: 15%;
    }
    #mdocs-list-table .mdocs-description {
        width: 30%;
    }
    #mdocs-list-table .mdocs-version {
        width: 9%;
    }

    If you didn’t do this, we will need to change our CSS to fix table display each time when you change your CSS. But this is just one problem. Other problem is that we can’t fix table issue in admin dashboard because theme CSS not loaded here. You can test this changes. Thank you.

    Thread Starter Ivaseg

    (@ivaseg)

    Next changes to CSS:
    <td id="" class="mdocs-tooltip mdocs-title" colspan="0">
    replace with:
    <td class="mdocs-tooltip mdocs-title" colspan="0">
    ————–
    <i class="" aria-hidden="true" title="Description"></i>
    replace with:
    <i aria-hidden="true" title="Description"></i>
    ————–
    <em class=""><p>docs description text goes here</p></em>
    replace with:
    <em><p>docs description text goes here</p></em>

    PS: Element p not allowed as child of element em in this context. But I don’t know if u can fix this. It’s not critical.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Try to avoid using !important’ is closed to new replies.