• Resolved tatof

    (@tatof)


    Hello,

    I have turned off the Trusted batch but it keeps showing on our page. On the right side where our chat should be! Now our chat is not usable.

    Even if I turn on the badge and select left side it shows right side.

    I don’t want to show the batch. please fix this bug.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter tatof

    (@tatof)

    Here is a screenshot, left the settings, right the live site

    Thread Starter tatof

    (@tatof)

    Please…

    Plugin Author vendidero

    (@vendidero)

    I can only imagine one of these 2 options:

    • You are using WPML and may have multiple channels (per language) configured – you might want to check that.
    • You are using another plugin/snippet/custom script that embeds the trustbadge. Please disable the Trusted Shops Plugin and see whether the trustbadge still shows or not.

    Best,
    Dennis

    Thread Starter tatof

    (@tatof)

    • You are using WPML and may have multiple channels (per language) configured – you might want to check that.
      Nope, no WPML installed
    • You are using another plugin/snippet/custom script that embeds the trustbadge. Please disable the Trusted Shops Plugin and see whether the trustbadge still shows or not.
      Nope only your plugin, when I disable the plugin the badge disappears.

    I made this CSS to remove the badge:

       ._t53mel,
        div[id^="trustbadge-container"],
        div[id^="maximized-trustbadge"],
        div[id^="minimized-trustbadge"]{
            display: none !important;
            z-index: -1 !important;
            opacity: 0 !important;
            pointer-events: none !important;
        }
    Plugin Author vendidero

    (@vendidero)

    Hi there,

    hm, that’s quite strange. I’ve noticed on your screenshot that you are using a caching plugin? Maybe a cached version of your site shows?

    Best,
    Dennis

    Thread Starter tatof

    (@tatof)

    Also when I delete all cache the badge is shown. (even when I disable the caching plugin) Tested it on multiple computers and different browsers. -> edge, chrome, firefox, safari, brave

    Weird part is that “align left” option also doesn’t work when I do enable it.

    Plugin Author vendidero

    (@vendidero)

    Hm, I was not able to reproduce this issue locally using the latest versions (Woo, TS Plugin, no other plugins, default theme). Could you share your websites URL to let me see the actual code generated in the frontend?

    Thread Starter tatof

    (@tatof)

    Sure:
    https://www.productlicenties.nl/

    I could also video call to show you its not caching

    Plugin Author vendidero

    (@vendidero)

    Ok, for what I can see via the source, rocket seems to be locally caching the actual script in a custom directory cache/min/1/js/X61E945FE64ACF1CFF26D97531641E811.js

    Do you have a staging env where caching can be disabled for a certain time?

    In case of doubt: Could you please disconnect via Trusted Shops > Settings (that will remove your settings, you’ll need to authenticate again and may choose your settings again) to make sure your settings are completely removed? To me this issue looks very much like the (trustbadge) settings are not being updated (correctly) in your wp_options table.

    Thread Starter tatof

    (@tatof)

    Hello, I disabled the caching and tried it on firefox -> private browser. It worked there 🙂 so thats good. also left -> right.

    Think my testing was not correct because of local cache or something. thanks. Remain two more questions.

    1. Why is the z-index this high? 2147483647? higher than that doesn’t exits.. terrible thing to do to other programmers… The badge is above the Cookie alert. I need to use CSS “hack” to make the badge lower.
    2. What local JS could I exclude from the cache? I don’t see any from your plugin only from “widgets.trustedshops.nl”

    Dear Tatof,

    Could you please email to the following email address with the issue:

    productintegration@trustedshops.com

    Then we will offer you support through that way.

    Best regards,

    Technical Support Trusted Shops

    Thread Starter tatof

    (@tatof)

    Hello TrustedShops support,

    The last questions are about this plugin and can help other users of this plugin. Don’t think it helps if I send it by mail to you.

    Plugin Author vendidero

    (@vendidero)

    Hi @tatof,

    regarding the local JS: There is no local JS in the frontend – your caching plugin seems to (locally) cache the external script.

    Best,
    Dennis

    Thread Starter tatof

    (@tatof)

    Oke thanks! then I have my solutions 🙂 sorry for the confusion

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Trusted batch doesnt turn off’ is closed to new replies.