Support » Fixing WordPress » truncated posts

  • Resolved daschan


    Hope someone here can help. WordPress seems to be limiting my posts to a fixed number of characters, whether I paste my text into the post field or type it manually. On saving, the post is truncated. I have tried to get around this by switching to html editor. When I update the entire post is visible in the draft box, but again on saving, the post is cut off. I am unable to publish the post in its entirety.

    Can this be a server-related problem? I’m not a techie, so if anyone has a clue what’s going on, please spell it out for me in layman’s language so I can understand or bring it to my ISP’s attention.

    I recently (about 1 month ago) upgraded from v.1.5 to 2.0.2, and since then I’ve been having this problem. Will upgrading again fix it?

    Haven’t modified the theme or made any other changes to wordpress installation except the upgrade.

    Many thanks in advance to whoever can help me out here. — D. Chan

Viewing 11 replies - 1 through 11 (of 11 total)
  • A link would’ve been priceless.

    What theme are you using? Does the problem persist if you switch to the default theme?

    Hi, here’s the link to the blog:

    But I deleted the post in question, and have since been trying to work with it as a draft.

    Since posting here, I backed up the blog and then updated to v2.1.3, but still the same problem persists, and now I find that there is no option to use an html editor :-(.

    Theme is Georgia (an old theme that was designed for WordPress 1.5, which I tweaked ever so slightly). I haven’t tried to switch to a different theme. Will do so and report back.

    Okay, I’m back, and tried switching theme to default. Sorry, problem is still there.

    Could there be a conflict with the webhost server software?

    Any help very much appreciated. Thanks again–D. Chan

    and now I find that there is no option to use an html editor

    Turn it on first. Users -> Your Profile. Check the top box.

    Are you familiar with the difference between the_excerpt and the_content template tags? I’d wager your theme uses the_excerpt in index.php.

    Oh oh, it’s me again. But I’ve discovered this same issue is also appearing in another blog I maintain, also v.2.1.3. Again, the post is truncated.

    Is it possible that the post (now only saved as draft) contains some character or word that is “out-lawed” or that conflicts with the php? (Sorry, I really don’t know anything, and am taking wild guesses at this point.) The post is long, 2312 words or 12,983 characters not counting spaces.

    The 2 different blogs are using 2 different themes. From what I can see, the index.php file inside the Theme folder merely calls up the post.php file–there is no request or call for the_excerpt or the_content in the index.php file. The post.php file calls for the_content. Here’s code from the one blog’s post.php file (using Connections Reloaded theme):

    `<p class="post-date"><?php the_time('D j M Y'); ?></p>
    <div class="post-info"><h2 class="post-title">" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></h2>
    Posted by <?php the_author(); ?> under <?php the_category(' , '); ?><?php edit_post_link('(edit this)'); ?><br/><?php comments_popup_link('No Comments', '1 Comment', '[%] Comments'); ?> </div>
    <div class="post-content">
    <?php the_content(); ?>
    <div class="post-info">
    <?php wp_link_pages(); ?>
    <?php trackback_rdf(); ?>
    <div class="post-footer"> </div>

    And here’s a snippet of code from the index.php file:

    `<?php get_header(); ?>
    <div id="main">
    <div id="content">
    <?php if ($posts) : foreach ($posts as $post) : start_wp(); ?>
    <div class="post">
    <?php require('post.php'); ?>
    <?php comments_template(); // Get wp-comments.php template ?>
    <?php endforeach; else: ?>
    <p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    <?php endif; ?>
    <p align="center"><?php posts_nav_link() ?></p>


    No mention whatsoever of the_excerpt.

    At any rate, this problem is happening even with the default theme.

    For the other blog now set to default theme, this is a snippet of code from the index.php file:

    `<div class="storycontent"><?php the_author(''); ?>
    <?php the_content(); ?>

    <div class="meta"><?php the_date(); ?> <?php the_time() ?> | <?php _e("Filed under:"); ?> <?php the_category() ?> | <?php edit_post_link(); ?>
    <span class="feedback"><?php wp_link_pages(); ?><?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)')); ?> </span>

    Hi again, just in case anyone decides to look at this thread and thinks of helping out. 15 hours after the problem appeared, it just as suddenly resolved itself. Or seemed to. I suspect that there was a glitch on the webhost server. Both blogs are on the same server. Now the blogs are working fine. Gawd knows. I sure don’t. So good luck to anyone else who runs into this weird behavior. I hope I have better luck next time too. Consider case closed for now.

    Far out. Glad to see the update. My next question was going to be “Have you checked your web server’s error logs?” Still might be worth a check. Maybe host got aggressive with mod_security or something?


    I am having the same issue. I wrote a long post, saved it, saw it published, went back to edit it, and only had three paragraphs showing. There was no way to recover the remainder. I can live with doing my writing somewhere else and pasting it in, but if it won’t post at all that is definitely a problem. Any ideas? website is: theme is cutline WP version 2

    This topic says resolved so maybe there is a standard answer now? Thanks,


    I had a similar problem last week, wrote a small post, saved and it went ok. Edited it, wrote a bit more, pressed the save button and it went back to the first version of the post.

    It was a problem with the database : a corrupt index in the wp_posts table. Try to export all the database, drop the tables and import them again. It worked for me.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘truncated posts’ is closed to new replies.