Support » Fixing WordPress » Truly Fatal Error: Fatal error: Allowed memory size of 8388608 bytes exhausted

  • I am receiving a truly fatal error and my site went to bits, I cannot edit, publish, nothing works, PLEASE help…

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 208834 bytes) in
    /home/*****/public_html/wp-includes/cache.php on line 48

    I tried to disable plugins but when I go to Plugins section on my dashboard I get the same error message! All plugins have disappeared so cannot disable anything.

    I read through other similar posts about this error but …
    – my site ( is very small, has only 2 posts (as static pages)

    – using only a few plugins
    cforms II

    I am not very technically minded and haven’t got a clue what to do, help me please ….

Viewing 9 replies - 1 through 9 (of 9 total)
  • The first thing to do is to actually delete the plugins that are on your server in the plugins folder, this will remove them from activating. I’d download them to your PC as a backup before deleting them of course.

    Then go back and try to login in. If it still gives you the same error then you’ll need to contact your server admin. The error you are getting has to do with PHP not having enough memory available to run a process. If regular plain old WordPress causes this then they have the setting waaaayyyy too low for anything to work on your server.

    If WordPress works after removing the plugins from the server, then it’s a case where one or a combo of them are pushing the memory limit too hard. I’d contact the server admin anyway and see if they can raise your PHP memory limit slightly. Otherwise you’ll have to do trial and error to see which one is causing the issue and see if you can find a different plugin to do the same job.

    In cache.php, add the following code at the top in line 2 just after “<?php” :


    If even then it fails, try increasing the 12M to 20M.
    After the upgrade runs successfully, you may remove that line or keep as it as you wish.

    Also see :

    That worked for me (the latest post) thanks!

    so far that worked for me too , thanks 🙂

    since I was having this problem with every .php file in the /wp-admin/ section, adding code to the file was a non-solution for me. I was able to to solve the problem with the .htaccess file – details at:

    Thank you riteshTilve, you are a life saver!! My site was having this error for months and whilst the pages did update the error kept happening. After doing many searches everyone kept talking about a php.ini file and what a pain as i never heard from my hosting company. I did the fix you mentioned and it works now, thankyou!


    Thanks! I had the same problem and that fixed it!

    Same problem with 2.5.1 but the code
    won’t help, it was like that even before the problem came up neither does deleting all the files and reinstalling.
    I also get this /home/*****/public_html/pokenblogi/wp-includes/streams.php on line 64

    Any ideas?

    I have my own server and even raising the memory limit to 256M won’t help. This started happening after moving to a server with PHP5.

    It seems WordPress has a 128M memory limit hardcoded somewhere. Any hints?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Truly Fatal Error: Fatal error: Allowed memory size of 8388608 bytes exhausted’ is closed to new replies.