Support » Requests and Feedback » Truly allow HTML editing!

  • It is impossible now for me to edit and add HTML codes without WordPress breaking it up with its auto formatting!

    WTH are you guys thinking!!!

    Is there a way I can truly disable this? Switching over from HTML view to Visual Editor view just breaks it up. WTH.

    I insert my ad code:

    <a href="" target="_blank">
    <img src="" width="468" height="60" alt="Parallels Desktop 7 for Mac" border="0"/></a>

    And it turns into

    <a href="" target="_blank">
    <img style="display: none !important; visibility: hidden !important; opacity: 0 !important;" src="" alt="Parallels Desktop 7 for Mac" width="0px" height="0px" border="0" /></a>

    What the hell we you guys thinking???

Viewing 9 replies - 1 through 9 (of 9 total)
  • Don’t switch between HTML view and the Visual Editor. This is a known issue with the TinyMCE editor.

    Just do everything in HTML view.

    Let me try that again. But my experience was that with 3.3, even doing everything in HTML view seems to have mess up the HTMLs…

    I just tried copying the chunk of code you provided in HTML view on 3.3.

    The code is saved exactly as copied.

    Perhaps you have a plugin which is interfering.

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    I have the same experience as fonglh. Works fine for me.

    So, this means that if you have a client who wants to work on his own website but doesn’t understand HTML, and you’ve just placed an AWeber optin form in a post or page using the HTML editor, but he comes in and insists on using the Visual editor, you now have to tell your client to never use the Visual editor on that post or page ever again, or else the form gets stripped out?

    Moderator cubecolour



    mitchpowell – there’s a plugin for that:


    Thank you for the suggestion, but I tried that plugin already. I installed and activated and configured it properly (I’m sure I did,) and it failed to actually disable the visual editor. The checkbox showed up on the right, I ticked it and updated the post, and the ‘Visual’ tab was still active. I updated the post after clicking the ‘Visual’ tab, and the script was stripped out of the page.

    This plugin, even if it did work, still doesn’t resolve my issue with my client, because he could untick the box anyway, insisting on editing pages and posts in the Visual editor. There HAS to be a way to keep an AWeber script in a post or page regardless of the editing interface.

    I’m not adept enough at shortcodes to write one that will do what I want. I’m trying some tutorials but time is an issue, and this is a bit of a learning curve for me. I’m also trying to make the Visual Editor match the styling as clos as possible to what shows on the front end, and this too, is taking a lot of time. I’d hire a real developer if I could afford it, but I can’t right now.

    Thanks again,

    Moderator cubecolour



    I’ve just tried the plugin & it works for me, so you may have a conflict with another plugin.

    Perhaps a front-end editor will suit you better if your goal is true wysiwyg:


    I once had a similar problem with one of my clients, one way I found to work around it was to incorporating the ad, or whatever other special coding you may have, into a template itself. For those specific pages displaying it, on the editing page, under “page attributes” and “template,” simply select whatever template option that page will have, then the client can’t mess up the specific special coding that is a part of that page.

    Setting up new template options is pretty easy and you can use z-indexing in the template to coax the lettering around whatever you are inserting/overlaying.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Truly allow HTML editing!’ is closed to new replies.