Support » Fixing WordPress » Troubleshooting WordPress 3.1 – Master List

  • 17-March – This post has been updated with all the information provided in subsequent posts. I also broke it out into per-topic posts so is easier to update.

    Remeber DO NOT requests support in this thread. We can’t move your posts, so we will just delete them.

    So OMGWTFBBQ!? WordPress 3.1 broke everything?

    Don’t Panic!

    Remember to be calm, be patient and be respectful. Volunteers are out here to TRY and help you, but we need your help too.

    The standard debugging methods always apply:

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – If all else fails, manually upgrade. Download a fresh copy of the file of 3.1 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    If you have the EXACT same problem, feel free to chime in on someone else’s topic. If you DO NOT have the exact same problem, DO NOT use someone else’s topic! It’s actually better to make your own topic most of the time. Also, if the topic is marked ‘resolved’ you should make a new topic. We don’t patrol resolved ones as often. Make your subject line descriptive “All permalinks broken since 3.1” instead of “AUGH! HELP! YOU SUCK!” (yes, real subject lines).

Viewing 13 replies - 1 through 13 (of 13 total)

    You can turn this off for yourself in your profile.

    If it’s throwing your theme out of whack, make sure you have a call to wp_footer() in your theme’s footer. The next cause for that is your theme’s css having a conflict. If it’s your avatar size, again, that’s CSS. Check out this link for more info:

    Wanna turn the admin menu ON for EVERYONE? Use the Always Show Admin Bar Function

    Like the bar but not the search? Hide Admin Bar Search Plugin is there.

    Want to minimise it? Admin Bar Minimiser Plugin

    Want to disable it selectively? Admin Bar Disabler Plugin can do that.

    Finally if you MUST turn it off…

    To disable it, you can add this to your functions.php

    /* Disable the Admin Bar. */
    add_filter( 'show_admin_bar', '__return_false' );


    /* Disable the Admin Bar. */


    /* Disable the Admin Bar. */

    OR use the Disable Admin Bar plugin.

    FYI, if you put the plugin in a folder called mu-plugins (yes, you can do this on Single Site as well as MultiSite) then your users won’t be able to un-install it unless they go in via FTP. Just put the mu-plugins folder in the same level as themes and plugins (wp-content/mu-plugins) and copy the FILE (not the folder) for the plugin into there. Done.


    From Nacin:

    Sorry all,

    The plugin was removed due to licensing issues. It should never have been included in WordPress, and was never used by many. It won’t be coming back to WordPress core.

    You should look at the oEmbeds feature:

    I imagine there are other plugins out there that may be able to leverage this, but the plugin would not be compatible with the WordPress license.


    Any plugin using the Super Admin menu got their menu items reshuffled. If you can’t find the Super Grover– ADMIN toolbar, look on your top RIGHT of your Admin

    If you’re behind a NAT proxy or a firewall and things are REALLY slow, try turning OFF your admin bar.

    From spherical:

    • Only the theme on the blog you are using to perform the upgrade (Primary Blog on Multisite) needs to be changed during the upgrade
    • Did rename the /plugins directory after deactivating plugins on only the Primary Blog; just to be sure nothing bad would happen in the background and to take advantage of the “Recently Active” list when I was finished
    • Did not rename /mu-plugins

    Full procedure used is listed here.


    Capital letters will mess you up. Basically, this was a BUG in 3.0 and was fixed around 3.1-RC3, but a lot of people were doing it anyway.


    You need to upgrade to BP 1.2.8.

    Also read this:


    3.1 hides some screen options on posts & pages edit screens by default. Just turn on the ones you want.
    More info here:

    Alternately, put this in your theme’s functions.php if you want the custom fields to show up by default (from this thread):

    // Change what's hidden by default
    add_filter('default_hidden_meta_boxes', 'be_hidden_meta_boxes', 10, 2);
    function be_hidden_meta_boxes($hidden, $screen) {
    	if ( 'post' == $screen->base || 'page' == $screen->base )
    		$hidden = array('slugdiv', 'trackbacksdiv', 'postexcerpt', 'commentstatusdiv', 'commentsdiv', 'authordiv', 'revisionsdiv');
    		// removed 'postcustom',
    	return $hidden;

    (By the way, if you ever customized yours, that’s why they didn’t vanish. It only changed for people still using default.)

    These plugins have been reported as either breaking your whole site, or simply NOT working on WP 3.1

    Many MAY have fixes at this point, so always check the plugin page and see if there’s a new version first.

    • Advanced Permalinks
    • Cforms (by delicious day) – Upgrade to the latest version to correct
    • Event Espresso and Easy Toolbox conflict, making it impossible to drag/drop widgets.
    • Facebook integration plugin
    • Facebook Like Button
      WordPress Facebook Like Plugin compatible with WP 3.1
    • Featured Content Gallery
    • FT Signature Manager
      causing an error message on the Visual Post editor that says “you do not have permission to do this”
    • Global Translator (maybe because of qTranslate)
    • Grooveshark prevents the ability to upload/insert images into posts. The button to upload an image is visible, but doesn’t actually do anything.
    • Multipage Toolkit. See: this post for details
    • multiple-post-thumbnails
      – multiple-post-thumbnails has been updated to 0.5 which updates the readme and FAQ to fix a problem when upgrading caused by the sample code in the readme not using a check for class_exists before using the class.
    • Post Editor Buttons ( )
    • qtranslate seems to fail on 3.1 as well (this may affect many plugins)
    • Rich Category Editor – It isn’t displaying any tinyMCE buttons
    • Scissors Plugin (breaks TinyMCE)
    • Simple Sidebar Share Widget
    • Simple Tags (uncheck “Active tags for page” ) – This has been updated for 3.1!
    • Theme My Login
    • TinyMCE advanced – It works but does’t seem to be using the new link to post feature.
    • op Level Categories (try switching to FV Top Level Categories BETA version)
    • Twitter Tools
    • Visitor-Maps and Who’s Online
    • P Auto Tagger
    • WP Footer Ad Plugin breaks the Edit Post page in the admin area with a jQuery conflict.
    • WP Hive Fixed! Read the notes
    • WP No Category Base – Now compatible with 3.1 – Mar 7
    • WP-Stats-Dashboard
      – visual editor broken
      – couldn’t insert media into posts
      – couldn’t add tags to posts.
    • Custom Post Type Archives: interferes with contextual help

    WP Pretty Photo and other jQuery sliders are breaking because of the new version of jQuery that comes with 3.1.

    See for WP Pretty Photo update.

    Two other plugins that stopped the media lightbox uploader.
    * NextGEN Gallery Version 1.7.4 | By Alex Rabe (latest)
    * Social Discussions Version 5.1.0 | By LinksAlpha (latest)

    Some category excluder plugins such as Ultimate Category Excluder may be broken as well. That one is actually a bug: Trac Ticket
    The Hotfix plugin now has a fix that might help:

    If you’re using FireFox, upgrade. There ARE issues with FF 3 and TinyMCE (which powers WP’s visual editor).

    Some plugins (like TinyMCE Advanced, Rich Category Editor and WP-Stats Dashboard) can also cause this.

    Some people have reported that adding this to their wp-config.php corrects the issue:
    define('CONCATENATE_SCRIPTS', false );

    As for link info not auto-completing, the devs are aware and are looking into this. No fix yet.

    Also remember: switching between editors is the second fastest way to drive you batty 🙂 Don’t jump between visual and HTML editors, that has NEVER been a good idea.

    Infinite redirects on IIS servers – Try using the Permalink Fix & Disable Canonical Redirects Pack

    The issues with IIS and permalinks will be resolved in 3.1.1 – the dev team is aware:

    Fatal error in the output means either your theme doesn’t like 3.1, you have a plugin that doesn’t like 3.1, or you have an incomplete upgrade.

    hertz suggests this if you have a fatal error with MultiSite:

    1. add define(‘WP_ALLOW_REPAIR’, true); to your wp-config.php
    2. open [your site]/wp-admin/maint/repair.php
    3. if everything fine in step 2, go to step 4 or try to solve appear in repair page(step 2).
    4. change your plugins and themes folder name to something
    5. delete wp-admin, wp-include and all files in your wordpress root except wp-config.php.
    6. add new update package in your wordpress installation.
    7 go to phpmyadmin and find all plugin related tables, keys and value and drop all.
    8. open again [your site]/wp-admin/maint/repair.php
    9. try to upgrade your network

    This INCLUDES links that break when you have category in the URL

    You may need to let WP regenerate your .htaccess.

    Plugins cause this too. Especially anything screwing around with permalinks or rewrites. Note – Simple Tags version 1.8 has issues with 3.1. so deactivate it or turn off ‘active tags for pages’ The 2.x Beta version of the plugin is working on fixing this, but be aware it IS a beta.

    FV Top Level Categories seems to have helped some people, while others have success with the Permalink Fix & Disable Canonical Redirects Pack. Try installing one or the other.

    Some people have found this helpful to fix redirect loop issues


    Older versions of Memcache may have issues, however there has not been enough testing of this one.

    Using the same names for tags and categories remains problematic, though this has always been a bit sketchy.

    From godlikemouse:

    If you run into the problem where your toolbar disappears from your WYSIWYG editor as well as the WYSIWYG editor not working at all, try this.

    go to your wp-includes/js/tinymce/langs and create a symbolic link to wp-langs-en.js as en.js.

    ln -s wp-langes-en.js en.js

    Looks like someone forgot to rename a file on the upgrade.

    From madpress

    Using a pre_get_posts filter in functions.php (to merge posts and custom post types) worked fine with 3.0.x, but seems to require an explicit is_admin check since 3.1, e.g.

    if ( !is_admin() ) {
    add_filter( 'pre_get_posts', 'funky_get_posts' );
    function funky_get_posts( $query ) {
    	if ( is_home() || is_archive() || is_search() || is_paged() )
    		$query->set( 'post_type', array( 'post', 'live-shows' ) );
    	return $query;

    Not using this is_admin check results in a warning (“Warning: Illegal offset type in isset or empty in /home/my-site/public/wp-includes/post.php on line 811”) and messes up the admin pages for custom post types.


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Troubleshooting WordPress 3.1 – Master List’ is closed to new replies.