Support » Fixing WordPress » troubleshooting why some posts don’t appear on some pages

  • Hello, I’m running into a problem I don’t know how to solve.
    Some posts of my blog (like this: [ redundant link removed ]) do not appear on my blog’s home page or on the news page (/news/) even though the post is associated with a category.

    What could prevent some posts from being shown across the site?
    Thank you

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • The source of your page shows a local cache Javascript from your theme, but also something from contact for 7, and Super Cache. I would first investigate Super Cache. I’m not familiar with how it works, but if it cached the category page and didn’t regenerate it when you write a new post, you would get this result. (but it seems that they would have that built-in)

    Thread Starter marcnyc

    (@marcnyc)

    Thanks @joyously
    I use the LightSpeed Caching pluing but upon your comment I just disabled it to check but the post still doesn’t appear in the home and the news page.
    I left the plugin disabled, would you mind checking and seeing if you still see those local cache JS? I’m not sure what you refer to

    I thought the theme’s Javascript was not affecting the problem, but here’s how I see it. Use the browser View Source option and search for cache:

    Looking at the code more closely, though, it is retrieving the posts with Ajax, so perhaps there is a problem there.

    Thread Starter marcnyc

    (@marcnyc)

    how could I troubleshoot this to know what’s happening?

    You should ask at the support forum for the theme (I think it says it’s theme Javascript).

    Thread Starter marcnyc

    (@marcnyc)

    Yes I did.
    It’s Newspaper X

    Thread Starter marcnyc

    (@marcnyc)

    I figured out that it’s posts that include quotes (“”) in the subject that won’t appear… I don’t have any plugins to exclude certain posts based on their content… how can I make sure this doesn’t happen?
    Thanks

    That sort of makes sense if you think about the Javascript that the theme is using. An unescaped quote could break the JS.
    In WP, the post title can contain HTML or quotes, just like the content can. Output of title or content is a direct echo, but everything else is escaped first.

    I suppose you could debug it yourself, or ask the theme author.
    Or do a search/replace on your titles to change quotes to curly quotes.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘troubleshooting why some posts don’t appear on some pages’ is closed to new replies.