Support » Fixing WordPress » Troubleshooting: Importing Blogger to new WP 2.8 blog

  • I just started a new WP blog, hosted on the server I’ve used for a Blogger blog for about seven years. I am using the Thesis them; just bought it today and activated it. I am trying to import Blogger posts. I’ve read a lot on this forum, but I either don’t understand it, it didn’t work, or they must be talking about a different WP dashboard…

    Anyway, here’s what I’ve done.

    My old blog(s) were all FTP, so I transferred them to a Blogspot blog. My new WordPress blog would not import that, however.

    Next, I started a temporary blog, and successfully imported the posts. Then I exported. Then I went to import to my WP blog on my server and received an error message after error message.

    wp-content/uploads server permissions was automatically set to 777 (I saw some people talking about that). Still no go. Tried the 755. Definitely no go. Have no idea what I’m doing.

    In the uploads folder, I see all the exported XML files sitting there. They were in a FILENAME.xml.txt form, so I took the .txt off. Nope.

    I also tried a blogger converting tool I saw on a forum post, but that bombed and really, I can get the blogger into the .com blog and export it as WP, it’s just that the server WP blog I’m trying to set up will not show any posts despite finding the files sitting in the uploads folder.

    Any help would be wonderful, since I hate to lose a grand total of about 3,000 posts (no, I’m not doing them all at once; I had a variety of blogs and am pruning and doing them piecemeal).

    Admittedly, I’m not a computer genius and I’m fairly new to .php stuff.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Anyone out there? I’ve been trying to figure this out for many days; I’ve read forum post after forum post here, and elsewhere, and no luck.

    I’m getting an error message as follows:

    Warning: gzopen(\\XXXXX\home\users\web\bXXX\XXXXXXX\blog/wp-content/uploads/\\XXXXX\home\users\web\bXXX\XXXXXXX\blog/wp-content/uploads/2009/01/wordpress2009-01-23xml11.import) [function.gzopen]: failed to open stream: No such file or directory in \\XXXXX\home\users\web\bXXX\XXXXXXX\blog\wp-admin\import\wordpress.php on line 73

    I found that other people have had this error, but for them, it “just went away.” No such luck here. Could anyone tell me what to do? My host doesn’t offer support past WP installation, and I’ve not gotten any support via this forum… anyone?

    What file/folder should the imported xml file be in? Should it be in the uploads folder or not? What do I need to do?

    I can import the RSS feed but, of course, I lose all of my comments. Not a great solution.

    Any attempt at WordPress or MT import…I get a similar error message as above.

    My friend can import my exported file with no problem in both 2.7 and 2.8 to his own server. The same file goes in the same place in his server as well. I’ve “borrowed” his wordpress.php file in case something was wrong with mine and still no luck.

    Hello Jules,

    Two things first:
    1 – See if you can restore permissions (currently 755) back to 777. This will eliminate any possible permission complications.
    2 – This may be a no brainer, but are you using the WordPress Dashboard to select your Import preference? It’s my understanding the XML tools are under –but the support pages I read recommend using the GUI dashboard instead.

    I’m using the following dashboard for importing:

    Not sure about how to get to the GUI (or what that is) dashboard?

    The permissions, by the way, have been changed to 777 and it still resulted in the same error. My settings are the same as my friend as far as what happens with an upload, and I’m using his wordpress.php file but all to no avail.

    Sounds like you’re using the correct Graphic User Interface (GUI) tool, versus using a command line–which could cause all kinds of headaches. (There was no doubt, but I wanted to confirm anyway.)

    Are your server permissions restored back to 777?

    Yes, they are all 777 (which I will have to change again after the hoped-for successful import, I know, due to security issues.) A friend recommended using FileZilla for the recursive CHMOD feature. It didn’t help; I still got the same error as I mentioned above.

    Ugh. Well, you’re doing everything I’d do. Great your friend recommended FileZilla. Well, permissions are good. And you’re using the dashboard. Very puzzling. Still researching.

    Using Notepad++ I am looking at the wordpress.php file, and at line 73 which seems to be the line in question. It says this for lines 67 through 74:

    function has_gzip() {
    return is_callable(‘gzopen’);

    function fopen($filename, $mode=’r’) {
    if ( $this->has_gzip() )
    return gzopen($filename, $mode);
    return fopen($filename, $mode);

    That’s correct, isn’t it?

    Yes, it looks correct. It’s my understanding “gzopen” is simply a file opening utility. So that should not be a problem.

    I am concerned with the PHP file not being able to open a stream. That would point (I think) to not being able to access the database, where the file location information is kept/stored.

    Your error message:
    failed to open stream: No such file or directory in \\XXXXX\home\users\web\bXXX\XXXXXXX\blog\wp-admin\import\wordpress.php

    It’s almost like the error is stating, because I cannot open a stream (to the database to find the file location) I cannot find a file or directory, this it does not exist.

    Hope that makes sense.

    I’m going to focus on WordPress setup permissions, as it talks using PHP (wordpress.php) and databases (either MySQL or Apache).

    I wonder if your friend can confirm certain permissions he has in place for his WordPress install:

    General file permissions (I agree to take them from 777 later)
    Permissions for PHP
    Permissions to whatever database he’s using on his server

    I was able to independently confirm WordPress does function as advertised with a new WordPress install this morning, running from a local box (using Linux Ubuntu). I believe what is suspect is your existing host server-side configuration and dependent services (PHP version 4.3 or greater, MySQL version 4.0 or greater, and a webserver [Apache].)

    Import function worked flawlessly from Blogger to WordPress.

    Unless the current host is willing to work with you–essentially proving WordPress does work on their systems–that leaves little option but to find a more amiable web hosting provider.

    I did send a support request to my host — — regarding my thoughts that the trouble was at their end. They responded to my first request by saying that once WordPress is installed, they offer no support. I have a feeling they wont’ do anything. If that is, indeed the case, I will either have to find a new host or find someone that will tell me how to do whatever it is I have to do through the control panels I have to make it work.

    We’ll see what they say. I’m not too impressed with them at this point; I’ve been with them for a decade and it’s been hit and miss.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Troubleshooting: Importing Blogger to new WP 2.8 blog’ is closed to new replies.