Support » Fixing WordPress » Troubles with Photoxhibit

  • Hi,
    I’ve been using wordpress and phoxhibit since old versions, but some troubles happened when i upgraded them to WP 2.5 and Photxhibit to 2.1.5.

    I didn’t get to customize my done galleries (like to import new images from Flickr, for example) and when i try to build some new gallery (importing images from Flickr too), appears a message “Please wait” and this message doesn’t leave. In the status bar appears a message like “Complete but whith errors”.

    Does someone have the same problem? Is a version trouble?

Viewing 12 replies - 1 through 12 (of 12 total)
  • I just installed the latest version, and also have the “Please Wait” issue… Anyone know why?

    Benjamin, we chatted last night about the “Please wait” issue, and you asked for my error log. I’ve managed to copy/paste it for you here…hope this helps!

    [Wed Apr 9 22:50:18 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/robots.txt
    [Wed Apr 9 22:50:18 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/missing.html
    [Thu Apr 10 04:36:30 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/robots.txt
    [Thu Apr 10 04:36:30 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/missing.html
    [Thu Apr 10 04:59:52 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/robots.txt
    [Thu Apr 10 04:59:52 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/missing.html
    [Thu Apr 10 05:26:39 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/robots.txt
    [Thu Apr 10 05:26:39 2008] [error] [client] File does not exist: /var/chroot/home/content/p/e/t/peterish/html/missing.html

    Hey Guys,
    First, sorry for the issues. I am finding the servers are much more different the each other then I originally thought.

    With that said, I have an idea why it is hanging, and it usually has to do with this line of photoxhibit/common/inc/px.php file:

    $imgs = $this->encodeToUtf8(stripslashes($post['images']));

    if you are comfortable, you can swap that out for

    $imgs = stripslashes($post['images']);

    and that “should” fix it.

    Problem fixed after doing that! 😀
    Thanks again ben

    Hey guys,
    I just posted a fix for this issue, please let me know if it works.

    Hey guys,

    I have problems with function Manage Album in Administration and also with uploading. When I want to upload photos it did not update px_photos database, also when I click edit images my images in Album does not show up… But everything else (Manage Gallery, Build Gallery) is ok.
    I have safe mode off and I used your fix, nothing help…. :(( Everything was ok at home, probably I have someting wrong in server settings, but I don’t know what it should be…

    Thank you for help

    WP 2.5 – photoxhibit 2.1.6

    If you go into photoxhibit’s options and turn the flash uploader off and then try to upload does it work? Some servers have issues with the flash uploader.

    Thank you for your advise, but it did not work 🙁 I think that photo uploader does not work with my database… Everything is ok on my localhost but when I migrated it on real server, it has problems…. Is it because of mysql 5 ??

    Thank you…


    I’m Having the same problem, both Safari and firefox just hans with the circular arrows this is the error firefox gives me.

    data.photoset has no properties
    Line 847

    I tried both fixes described here with no luck

    help appreciated jeje




    I am on the “Build Gallery” Page.

    I select the picasa radio button. When I click on “Next” nothing seems to happen.

    I am using WordPress 2.6

    Then I saw your solution and removed

    $imgs = $this->encodeToUtf8(stripslashes($post['images']));

    Still its not working for me even after deactivating and activating the plugin

    Photoxhibit is a great tool.
    Unfortunately I did the WordPress upgrade to 2.6 without testing all the functionality on my local server and now I’m in the same trouble that picasa upload stops with a “please wait” message.
    Does anyone have an idea what to do – and – hopefully not to downgrade to WordPress 2.5 …

    Hi I have tried removing $imgs = $this->encodeToUtf8(stripslashes($post[‘images’])); as suggested to no avail, has there been any progress with this bug? I am still seeing “Please wait” when i try to either edit or build a gallery it just sits there like that, I am using the latest version of wordpress 2.6.1

    Many thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Troubles with Photoxhibit’ is closed to new replies.