WordPress.org

Support

Support » Plugins and Hacks » Events Manager and WPML Compatibility » troubles with compatibility plugin

troubles with compatibility plugin

  • Hello,

    I tried to uninstall and reinstall this plugin, AFTER installing and activating first WPML, then EM, and I still got this error appearing when loading any page on dashboard. Could anyone help me with this? Thanks in advance.
    Toni

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘EM_WPML_Admin::init’ was given in /home/ledianhu/public_html/wp-includes/plugin.php on line 406

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/ledianhu/public_html/wp-includes/plugin.php:406) in /home/ledianhu/public_html/wp-content/plugins/events-manager/classes/em-notices.php on line 11

    Warning: Cannot modify header information – headers already sent by (output started at /home/ledianhu/public_html/wp-includes/plugin.php:406) in /home/ledianhu/public_html/wp-includes/option.php on line 568

    Warning: Cannot modify header information – headers already sent by (output started at /home/ledianhu/public_html/wp-includes/plugin.php:406) in /home/ledianhu/public_html/wp-includes/option.php on line 569

    http://wordpress.org/extend/plugins/events-manager-wpml/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Anyone? I am searching on the net, as much as i can, but really, I´m too newbie.

    In plugin.php the line 406 it refers to is
    call_user_func_array($the_['function'], array_slice($args, 0, (int) $the_['accepted_args']));

    And the only file where a line refers to EM_WPML_Admin::init’ is
    em-wpml-admin.php, last line :

    add_action('plugins_loaded', 'EM_WPML_Admin::init');

    And if I keep the plugin activated, the short codes like events list wont return any result anymore. If I deactivate the Events Manager and WPML Compatibility plugin, they display events again.

    I´ve run a complete reinstall of wordpress, installed only EM and WPML before the compatibility plugin, and I still got this issue.

    I have the same problem, @moresto

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'EM_WPML_Admin::init' was given in /home3/doblcrsc/public_html/wp-includes/plugin.php on line 406

    a solution to please @marcus

    Thanks

    I also have this problem, any soloution on the way?

    Plugin Author Marcus

    @netweblogic

    this should be fixed in 0.2

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘troubles with compatibility plugin’ is closed to new replies.
Skip to toolbar