Support » Plugin: Gwolle Guestbook » Trouble with YooTheme Pro?

  • Hi Marcel,
    just yesterday I installed your guestbook (and also bought the addOn ๐Ÿ™‚ ), but it seems to interfere with my theme YooTheme Pro. The pagebuilder within YouTheme Pro is not accessible anymore. When deactivating guestbook, it again works fine.
    “Fun” fact: After installing, it first worked perfectly together, but for some reason, after logging out of the backend and logging in afterwards, YooTheme seems to have trouble…???
    Do you have any clue?
    Best Regards,
    Tom

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Marcel Pol

    (@mpol)

    Hi Tom,
    Not sure what is happening.
    I don’t have access to that theme, I suppose it is a commercial theme?
    Could you send the zipfile to marcel@timelord.nl so that I can try it out myself? It is only for debugging purpose, so don’t worry about the license.

    Thread Starter timknopf

    (@timknopf)

    Wow!!! What a quick answer! I am impressed! Thank you!
    I just figuered that it is only a matter of the addon… ๐Ÿ˜ฎ
    You mean a zip of the theme you want me to send?

    Thread Starter timknopf

    (@timknopf)

    And yes, it is a commercial theme. One of the best in my oppinion… ๐Ÿ˜‰

    Thread Starter timknopf

    (@timknopf)

    Hi Marcel…
    OK, i figuered it out: It’s a problem together with my content-blocker (Borlabs-Cookie borlabs.io)… For DSGVO-Reasons, I want to block gwolle-gb as long as the visitor does not agree to “external cookies”. Therefore I need to block the script. At present, I am blocking those three scripts: gwolle_gb_addon_frontend_js, gwolle_gb_addon_rateit_js, gwolle_gb_frontend_js.
    Do you have a recommendation, which (combination of) sctipt(s) is needed to block?
    The problem seems to be the unblocking of the scripts…

    Have a great day, Tom

    Plugin Author Marcel Pol

    (@mpol)

    Hi Tom,
    Good that you found out where the problem is.

    If it is about external cookies, that is not happening by default in this plugin. Only when certain settings are enabled and when the visitor is doing some actions.

    For the plugin and the add-on there is default text that can be added to the privacy policy.
    I will paste below here what is already there.

    Default plugin:
    When visitors leave entries on the site we collect the data entered in the guestbook form and possibly the IP address and hostname of the visitor to help spam detection.

    An anonymized string created from your email address (also called a hash) may be provided to the Gravatar service to see if you are using it. The Gravatar service privacy policy is available here: https://automattic.com/privacy/. After approval of your entry, your profile picture is visible to the public in the context of your guestbook entry.

    The entered entry and its metadata may be sent to third parties like Akismet and Stop Forum Spam to help spam detection. Their respective privacy policies are at https://automattic.com/privacy/ and https://www.stopforumspam.com/privacy.

    Add-On:
    When visitors report an entry as abusive, the entry ID will be stored in a cookie in the browser. Also, the IP address will be saved temporarily in the database together with the number of reports.

    I think the first issue can be disabled in the settings for the guestbook, to not store the IP.
    If Gravatar, Akismet and Stop Forum Spam are not enabled point 2 and 3 are no issue.

    The cookies for the add-on are also used for likes, not just reports. These are functional cookies. If I am remembering correctly you can still use those, even without consent.
    I will see if I can improve that text, it hasn’t been updated for added features in the last 2 years.

    So if it is about cookies, the JavaScript should not be a problem.
    If you want to disable submission in the form, there might be a better way to do that. Maybe the form button can be hidden in CSS, or the submit button can be set to disabled with that attribute.

    By the way, it is Sunday, so I might be getting slower today ๐Ÿ™‚

    Thread Starter timknopf

    (@timknopf)

    OMG… it is sunday… ๐Ÿ™‚ So even a bigger THANK YOU!!!
    Ok, got it. I’m not a lawyer and for the DSGVO seems to be more complex than the comlete log-file of the first launch of the space-shuttle, I am quite unsure, about setting of cookies at all. So, to be on the safe side, I’ll keep on trying. As I found out a solution, I’ll be back again to share my knowledge…
    Until then…
    My great appreciation for your help!
    Enjoy the rest of the day!
    Tom

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Trouble with YooTheme Pro?’ is closed to new replies.