Support » Plugin: Classic Smilies » Trouble with the alignment (on smilies)

  • Resolved yesper

    (@yesper)



    Hello-a,

    And thanks for the nice plugin.

    However, there’s something odd in smilies alignment. They are not in “middle” in vertical direction. Here’s my site: JukeBlogi

    As you (might?) see the graphic smiley “jumps up” and even destroys the line-height.

    I tried to use this quick workaround by CSS:
    .wp-smiley: {vertical-align: -40%;}

    At first it worked, but then suddenly the effect disappeared. I saved again (the internal CSS in WP), and effect returned. Very weird. Also, this kind of alignment does not look precisely the same in Mac and Windows, so it’s is not a good solution.

    Any clue, what might cause the trouble here?

    https://wordpress.org/plugins/classic-smilies/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Your theme puts a margin-bottom of 0.5em on all img tags. Smilies are imgs too.

    Line 911 in your style.css file.

    Also, you forgot the “v” in “vertical”.

    Many thx for your quick answer!

    Oh dear. That tiny CSS definition of my own was added about 10 years ago; I had forgot it.

    Actually, I don’t use any graphic smilies myself, I have disable them in WP. But many of my customers do, so I started to investigate what’s up.

    And no, I had not forgot that »v». It’s just my way to disable CSS, temporarily. 😉

    Everything’s alright now. Thank you so much for your kind help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Trouble with the alignment (on smilies)’ is closed to new replies.