Support » Localhost Installs » Trouble with subdirectories

  • Hello,

    I have ran into a bit of trouble configuring wordpress on a local server using Apache. I have other non-wordpress projects that I work on, so I want to be able to make a specific subdirectory (called wordpress) that will hold all of my wordpress config files and it’s sub directories. Everything was working fine at first, until I decided to change my permalink from the default to a custom (/%category%/%postname%/). Since this change, I have not been able to access any of my pages, besides the homepage. Whenever I try too, I get an error stating that this object does not exist.
    Wordpress is able to write to my .htaccess file and even though the page cannot be displayed, the url in the address bar is what I wanted.
    I even tried to make a directory within the wordpress directory myself (with the proper permissions) and still no dice. I guess I am confused as to what goes into the sub directory I wish to create in order for wordpress to properly access it.
    Although this is only local and I could easily go back to the default permalink, I would still like to know what is the problem.
    I am new to CMSs and any advice will be greatly appreciated.


Viewing 9 replies - 1 through 9 (of 9 total)
  • Is mod_rewrite running on your server?

    I’m new to apache, how do you check if it is?

    I have the same problem, (newbie), and just ran this mod-rewrite check and the google site came up fine.
    I did this from the root but not the root of my wordpress site, if that makes a difference.
    The 404 error persists. I only have a few pages on the site, hoping to fix this first off, before going much further.

    I should add that like our friend above, the url shows correctly but the page has the google broken link page

    The end of my url reads: category/blog-it/

    I finally got mine working successfully. If you’d like, I can try and help you figure your problem out as well.
    For me, the following worked:

    I wrote a new directory tag, with the directory of choice, in the httpd.conf file with only the “Options” and the “AllowSymLinks” attributes.

    For instance: I wanted my url to look like “localhost/wordpress/category/postname”

    So I put the following into the httpd.conf file:

    <Directory "/srv/http/wordpress">
    AllowOverride All
    Options FollowSymLinks   

    (I’m running arch)

    Then restarted the apache deamon and rewrote the .htaccess file.

    One problem I ran into is that, without noticing, I had a subdirectory within my wordpress directory that had the same name as what I wanted the path to be. I guess wordpress dosn’t allow that, so make sure you delete (or rename) every directory within the wordpress directory that you wish to access.

    If this dosn’t work, try checking your permalinks settings.
    I have: /%category%/%postname%/ within the custom field, and everything seems to be working.

    Hope this helps!

    The problem I have here is that I’m not running it on my server.
    I know the thread header shows me to be an idiot but you had the same problem as I so I went with it.

    I can’t reboot the deamon..

    I installed the two latest hotfix’es. .8 and the WCS Custom Permalinks Hotfix

    It shows them active and if I ftp in, it shows them in the pllugins directory.
    Still know joy with the permalinks problem.
    I also have a problem with the media upload. It does not error but it does not upload either. It shows it there but there is an X through the thumbnail. My wordpress name and password are the same as for my ftp.
    And the user rights are ok. The glitch seem related..

    Oh, sorry, I forgot to thankyou for the responce. Thanks for the help.

    I’ve been using the free core FTP program.
    I found that if I chmod all rights, user group, world with read right execute the media uploader will work fine. Of course we don’t want that we only want user checked with read right execute..
    So if I login and run admin, and I’m able to build pages, why won’t the same rights let me upload?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Trouble with subdirectories’ is closed to new replies.