[resolved] Trouble with RSS2 feed (7 posts)

  1. Melatonin
    Posted 10 years ago #

    The RSS2 feed on my main page is working ok but when i click to comments section of any post and try to click RSS2 feed of that specific post i get and error like this ;

    XML Parsing Error: not well-formed
    Location: http://blog.serhatedip.com/?feed=rss2&p=11
    Line Number 18, Column 19: AND post_date < '2005-08-28 09:26:59'

    I am using 1.5.2 version and i'm quite sure its something about dates but i really cant figure out whats wrong with my dates and i couldnt found any similar problems at the forum.

    any ideas or recommendations will be greatly appreciated.


  2. Kafkaesqui

    Posted 10 years ago #

    If you look at the page source in your browser, you'll see it's from a WordPress database error. The error states in part:

    [Unknown column 'comment_post_id' in 'on clause']

    I can't say why this error is occuring, since A. I don't see a problem with the query as displayed in the source, and B. lacking that column in the comments table would cause this error elsewhere on your blog.

    Only thing I can think of at this time is to delete and then upload a new copy of wp-commentsrss2.php.

  3. Melatonin
    Posted 10 years ago #

    hi Kafkaesqui,

    i tried what you said but its still giving me he same error message :(

    by the way i checked mySQL tables and there wasnt any comment_post_id but there was comment_post_ID, i am not sure i have to add that row to the comments table, what do you think ?

  4. Kafkaesqui

    Posted 10 years ago #

    With MySQL, capitalization in column names *should* be ignored. At issue here is it should work as is, but if you want to give it a try, you could see about editing the wp-commentsrss2.php file, look for the two $comments = $wpdb->get_results lines, and where it has:

    comment_post_id = id

    change it to:

    comment_post_ID = ID

    I'll be surprised if it works (but then I am often surprised when it comes to computers). Note: before editing the file make a copy of it for *protection*.

  5. Melatonin
    Posted 10 years ago #

    adding removing data field didnt worked too, this is a weird weird problem grr :(

  6. Melatonin
    Posted 10 years ago #

    I still need help.

  7. Melatonin
    Posted 10 years ago #

    ok, i resolved the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic