Support » Fixing WordPress » Trouble with permalink options

  • Hi, I’m new to WordPress, so please be gentle and patient.

    Right now I’m building a site on a local host and problem is: I want to change my permalink options from predetermined to day and name. So I check the option in my WordPress desk, in Settings > Permalinks, but when I navigate my site and clic on the date of any post, I get the posts from another date! The site apparently defaults all dates to January, so, if I’m looking for the posts of June 17th, 2010, for example, instead of returning 2010/06/17, the site returns 2010/01/17 posts. And it happens with every date. But I don’t have this problem if I change my permalink options to predetermined.

    One more thing: my site is in Spanish, so I’ve changed the names of days and months from English to Spanish in my locale.php. Maybe this has something to do with the problem. Also, this is the portion of code in my index.php, archive.php, search.php and all documents with posts and entry utilities:

    <div class=”entry-utility”>
    Esta entrada fue publicada el
    ” title=”Archivo”><?php the_time(‘j \d\e\ F \d\e\ Y’) ?>


    which I checked and rechecked, again and again, and I don’t seem to find the solution. Thanks in advance for the help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Sorry, I think I posted the code incomplete:

    <div class="entry-utility">
            Esta entrada fue publicada el
            <a class="url fn n" href="<?php echo get_day_link( $year, $month, $day ); ?>" title="Archivo"><?php the_time('j \d\e\ F \d\e\ Y') ?></a>

    Thanks again.


    Set your desired wordpress permalink from admin area and add this code in htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Now, check with blog posts and pages.


    Shane G.

    Sorry again, please disregard the tags and the points in between. I was just trying to point that there goes more code which is not pertinent to what I’m asking.

    Tnanks Shane, but it didn’t work. I also tried changing the fourth line to:

    ErrorDocument 404 /wordpress/index.php?error=404

    But it still doesn’t work.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Trouble with permalink options’ is closed to new replies.