Support » Fixing WordPress » Trouble with MAMP and WP

  • Resolved wee-beastie



    I have been working locally on a site using MAMP. All was well until I decided to move the site onto my remote server for testing. I was following some step-by-step instructions, but I must have botched it up.

    I went to Settings > General and changed the urls in the WordPress Address, Blog Address fields to what they were going to be on the remote server. When I hit “Save Changes” everything went down.

    Now I cannot access the database, phpMyAdmin, etc…

    When I start up MAMP, I get the following warning:
    You don’t have permission to access /MAMP/ on this server.
    Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 Server at localhost Port 8888

    Any help would be greatly appreciated. My goals are to rescue the info in the database and get MAMP working again. Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hello.

    I got exacltly the same problem over here. Changed the name of the wordpress directory from within wordpress and since then I get the You don’t have permission to access /MAMP/ on this server.
    Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 Server at localhost Port 8888 warning.

    I skimmed the Apache, Mysql, php and other sites in search for solutions but i haven’t found any satisfying answer. I did a simple thing; changed the name, and it seems so incredibly difficult to change it back. I deleted MAMP and wordpress many times and reinstalled them again. Restarted over and over and even updated to 10.5.7. Defragmented, cleaned up, anything that could be possibly helpfull…

    Is there anybody who can get us out of this mess?

    Thank you so much in advance.

    I am having the exact same problem. I changed the url under settings from localhost to the actual domain name before I wanted to export the database for deployment live. Now I am stuck. I tried to dump the database via commandline but I just got a zero K file. When I try the dump again I get nothing at all.

    I use MAMP all the time to create sites locally and then when they are ready I upload them to the remote server ready for the site to be online. Here is what I do once the site is finished:

    Login to phpmyadmin through the MAMP homepage. Export the database using the PHPmyadmin export tool. This downloads a .sql file to your machine (I put it on the desktop)

    Open this .sql file in a text editor (textedit is fine on the mac) and then do a find and replace. Find all instances of your local URL (mine is always http://localhost:8888/sitefolder/) and replace with the new URL of the were the blog will be once on the web. Save the file.

    On the remote server in PHPMyadmin import this .sql file to your database.

    Upload all the local files to your server.

    Go to the new address of the blog on the server and all should be fine and work as it did locally.

    TIP: sometimes I have to browse the options table in the database using PHPMyadmin and change the blog address to the new remote address and also the wordpress address. Sometimes the find and replace does these two values, and sometimes it doesn’t. I am not at all sure why!

    It’s only one or 2 entries in the options table..

    Just pop open phpmyadmin and browse the wp_options table for the site url, update the entries manually..

    It’s literally 1 or 2 entries, and takes 2 minutes at most…

    I can create a query for you to use in PHPMYADMIN if you still have trouble… 🙂


    @equaldesign – These are some good tips. I should have been more careful when getting ready to upload. I will definitely review this thread next time I have to upload a WordPress site. Unfortunately, the problem I am having, is that I can not access phpMyAdmin at all. I can’t use MAMP at all.

    @ibookster – I did that too and got the same results. I ended up using the command line to comb thru the database table by table to find the content that I really wanted to save. I then cut and pasted the content as needed into my WordPress install on my hosted server space. I am working on the site remotely right now as MAMP is of no use to me at this point.

    @sakshin – Same here, and no luck. I am considering restoring from a backup that is approaching a month old. I really don’t want to have to do that.

    Can anyone recommend a resource for building and testing PHP sites locally besides MAMP? Also, if you guys manage to iron out this issue PLEASE post the solution! Thanks!

    Uniform Server..

    Been using it for years..

    Not sure how it compares to MAMP, WAMP, and all the other AMP like names, because i’ve never used them…. i understand they all do the same thing though in essence..

    Thanks! I will check this out. I should mention that I am working on a Mac. I do have Windows installed and vmware so this may come in handy. Thanks again!

    One thing I would try, is to look at the configurations as follows:

    go to your MAMP folder

    open that file, and look for the server name and document root path
    change to the new server and location

    Hope this helps.

    The MAMP forums are back up!! And I think I may have found a fix. I opened Applications/MAMP/conf/apache/httpd.conf and edited the code below:

    <Directory />
    Options Indexes FollowSymLinks
    AllowOverride All

    and changed All to None to end up with this:

    <Directory />
    Options Indexes FollowSymLinks
    AllowOverride None

    @buddha trance – Thanks for the tip, the document root seemed to be correct. Thanks though!

    WARNING: I have not fully tested this solution, but the start page is now usable again, which is encouraging. Let me know if it is working out for you guys!

    Tip found here:

    Yeehaah. It worked. I can’t believe it. Changing All to None and restarting the servers did the trick. I can access everything again, although I lost al my work in the re-re-re-installation process, I’m locally only again. Thank you We Beastie and the otheres for helping out. I owe you one.


    Hey there is more to the story that you might be interested in. A fellow who goes by angelwatt over at has been helping me out with this. He said that the warning that we were getting may have something to do with an .htaccess file. I used TinkerTool to show hidden files. Sure enough I found one at the root level of my hard drive. Check this link to the thread over at MacRumors to see what I found and a possible fix. Angelwatt provided a couple of useful links in the thread. FYI…

    HIya there!

    Since the solution of deactivating the AllowOverride made my parmalinkd useless, i wasn’t so satisfied about this. So i decided do dig it a little mode and on the mamp forum link offered by “Wee Beastie” upper, i just found a post by somebody under the nick of “lenaluna”

    here what the person was saying:

    found a solution for my problem with MAMP.
    wordpress had put a .htaccess file in the root level of my hard drive. something like this:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /ExampleSite/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /ExampleSite/index.php [L]
    # END WordPress

    I’ve deleted the file, as it should not be in the root of my harddrive anyway and now MAMP is perfectly working again.
    hope this will help other people to get around this strange problem.

    So in order, if you want to delete this file, you got to activate “hidden files viewing” in the terminal by typing this

    defaults write AppleShowAllFiles TRUE

    and this
    killall Finder

    After, you go in the computer root and this should be there, now delete it and to get all this crap working again as it should had…


    @wee Beastie Brilliant, thanks for that solution. This has had me really concerned for the last 30 minutes!


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Trouble with MAMP and WP’ is closed to new replies.