WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery Voting » [Resolved] Trouble with getting voting to work

[Resolved] Trouble with getting voting to work

  • I’ve tried to make this work but I am having problems. I created a photo gallery page with links to two separate galleries using nextGen shortcode on each of them like so: [nggallery id=1][ngg_uploader id=1]

    Then I went into nextgen-gallery/view/gallery.php and made changes like so: ` <!– Thumbnails –>
    <?php foreach ( $images as $image ) : ?>

    <div id=”ngg-image-<?php echo $image->pid ?>” class=”ngg-gallery-thumbnail-box” <?php echo $image->style ?> >
    <div class=”ngg-gallery-thumbnail” >
    <a href=”<?php echo $image->imageURL ?>” title=”<?php echo $image->description ?>” <?php echo $image->thumbcode ?> >
    <?php if ( !$image->hidden ) { ?>
    <img title=”<?php echo $image->alttext ?>” alt=”<?php echo $image->alttext ?>” src=”<?php echo $image->thumbnailURL ?>” <?php echo $image->size ?> />
    <?php } ?>
    </a>
    </div>
    <div style=”text-align:center”>
    <?php echo nggv_imageVoteForm($image->pid); ?></div>
    </div>`

    I also have the config set to show images enabled (not gallery), users don’t have to be logged in to vote, number of votes allowed=one per image, allow users to see results=image, rating type=star rating.

    Link is here: Gallery

    What am I missing?
    http://wordpress.org/extend/plugins/nextgen-gallery-voting/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author shauno

    @shauno

    Hi nootkan
    When you say you’ve set the config to show image voting, do you mean you set it individually per image from NGG’s ‘manage gallery’ page, or do you mean you set the global option on NGG Voting’s setting page?

    Ah I see there is another place to configure the voting plugin. I have it working now. Is it possible to allow voting for each individual image instead of for the gallery as a whole?

    Never mind got it figured out. Thanks for a great plugin.

    Plugin Author shauno

    @shauno

    I’m glad you got it figured out! I hope you enjoy the plugin. Let me know if there is anything else I can help with.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Trouble with getting voting to work’ is closed to new replies.
Skip to toolbar