WordPress.org

Support

Support » How-To and Troubleshooting » Trouble with exporting blog

Trouble with exporting blog

  • Anatoly

    @sublime-oblivion

    I’m exporting my blog (25MB) to another domain.

    There are two problems.

    1. I have to export in chunks (10MB limit), so I use this plugin.

    http://www.rangerpretzel.com/content/view/20/1/

    It’s very helpful, but unfortunately, file attachments are getting lost in the process.

    Is there a way to solve that?

    2. How do I export the results of past polls? (WP-Polls plugin)

    Just copying the file doesn’t seem to work.

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Anatoly

    @sublime-oblivion

    Re-WP polls, I tried importing the SQL database (wp_pollsa, wp_pollsip, wp_pollsq) but it does not seem to work.

    EDIT: Never mind, it works!

    Now there’s only (1) left to solve.

    PS. If I am unable to import attachment, as explained above, is there a way to restore post attachments by importing a particular database via phpMyAdmin?

    Anatoly

    @sublime-oblivion

    I tried breaking down the blog to chunks under 25MB manually by only exporting date ranges (e.g. Feb 09-Sep 09) into WXR.

    But this method doesn’t pick up the file attachments either. Surely this is a bug with the WordPress Importer?

    Anyhow, still thinking about this. I suppose I can restore image links by copying the Media files folder directly, and doing a Search and Replace on all instances of uploads/???. But it would be more convenient to retain the particular file attachments for each post.

    Anatoly

    @sublime-oblivion

    Just came across this post.

    (Sorry if it appears I’m talking to myself, but if no-one is replying…)

    http://wordpress.org/support/topic/importer-not-downloading-all-file-attachments-images-from-wordpresscom-blog?replies=6

    This, moving the images as well as the posts, is a fundamental aspect of ever moving a blog completely from WordPress.com to anywhere else, and there is still no well-defined way to do so reliably.

    Should I take it then that for a large WP blog (>10mb) hanging onto the file attachments is unrealistic?

    Hello I’m trying to do an export of garyengbergoutdoors.com because I’m building an updated subdomain. The current site is running very old WP version 2.1, and when I try to export, I get the following error.

    No webpage was found for the web address: http://www.garyengbergoutdoors.com/blog/wp-admin/export.php?author=all&submit=Download+Export+File+%C2%BB&download=true
    Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

    I know I could try doing an update before doing the export, but I am concerned it will not work correctly and I don’t want to have the live site not functioning correctly.

    Thank you in advance for any help you have to offer with this!

    Pedro

    @petredobrescu

    Hey all,

    I had the same issue with:

    Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

    I tried increasing php_memory_limit and even php_max_execution_time with no results. What fixed the issue for me and the export could be done, was to disable JetPack plugin. After that I could do the export without any issues.

    Hope this helps someone!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Trouble with exporting blog’ is closed to new replies.
Skip to toolbar