Support » Plugin: PowerPress Podcasting plugin by Blubrry » Trouble with Blubrry PowerPress – podcast not updating in iTunes

  • Resolved Mathias



    We are currently using PowerPress for creating an automatic RSS feed. The actual episodes are stored within our site + on SoundCloud.
    In each blog post containing a new podcast episode we embed the Soundcloud Player. This solution is currently the best one for us and it has been working just fine up until now.

    Now to our problem: up until x-mas, everything worked just fine. But with our latest two episodes we have encountered some problems with iTunes not updating with the latest episodes. For the episode published in Feb, it took a couple of days and suddenly it just appeared. The latest episode published this Tuesday (01-04-2014) is still not appearing in iTunes. We havent changed anything in the settings, it just stopped working the way it did last year.

    Link to our podcast RSS feed is here:

    Side note: WordPress version is 3.8.1 and version of PowerPress is 5.0.7.

    Edit: Also, when I click on Validate feed, I get a message saying the feed is valid. However, in that validation window our latest episode isnt showing. But when clicking directly on the URL to the feed (the URL above), the episode with description is there. The same problem occured with the 2nd latest episode, but when we noticed it appearing on iTunes it also was showing via the “Validate feed” link.
    Somehow information doesnt update the way it should…

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Angelo Mandato


    You are currently using PowerPRess 5.0.5 (Latest version just came out last night).

    Bottom of your feed has HTML comments from your wp caching plugin. See code below. Known issue that if your feed has HTML comments at the bottom iTunes will not update the directory listing.

    Reason your latest episode is not in the feed is more than likely your caching plugin as well. (no way around that, you have to clear it’s cache when that happens)

    Simply update PowerPress, clear the cache in your w3 caching plugin and you should be good to go (Latest version of PowerPress removes these comments that your caching plugin leaves).

    <!-- Performance optimized by W3 Total Cache. Learn more:
    Page Caching using disk: enhanced
    Database Caching using apc
     Served from: @ 2014-03-19 18:26:26 by W3 Total Cache -->

    Hi. I seem to be having a similar problem: my last three episodes were not updated neither on iTunes or while using the URL in an aggregator. What’s strange is I can see the episodes in the feed XML…

    I don’t have the same plugin as Mathias, and everything is up to date.

    Feed URL:

    Any help would help. Thanks!

    Plugin Author Angelo Mandato


    MrDenis, for what ever reason your last 3 episodes do not show “enclsoure” attributes. If you have Firefox, view the feed in Firefox, you will see there’s no podcast episode media for the last 3 episodes.

    Follow these instructions to diagnose what theme or plugin is causing the problem:

    Thanks for the quick reply Angelo.

    I’ve tried the basics to no avail: I reverted to all three basic themes, and I already had no other plugins installed aside from PowerPress…

    I’m a bit weary of deleting anything since I’m not extremely confortable with WP and I’m concerned it will destroy data. What should I try first? Resintalling PowerPress or WP?


    Found it!

    Before the last three episodes, I was using an absolute link to attach the MP3 file for the podcast when adding the post. After getting tired of it, for the last three I started using relative links (../wp-content/ and so on).

    This seemed to have busted the feed generation somehow. That is odd because I took great care to press “verify” before posting, and PowerPress was giving me a Podcast Verified message.

    This might be a bug? Or maybe a future feature? See I find the process of finding the podcast files on my server quite tedious and having to enter absolute links only sets up later crashes if anything changes in the server structure…

    Thanks again!

    Thanks for the quick reply, Angelo.

    When I am logged in, the version of PowerPress says 5.0.7 and did so at the time of my post (after clicking the Clear Plugins Update Cache the version reported in the footer of the page changed from 5.0.5 to 5.0.7).

    I will contact the admin of the site and ask him to update PowerPress (if needed) and to clear the cache in my w3 caching plugin.

    Plugin Author Angelo Mandato


    Mathias, looks like you’re all set.

    MrDenis you should be using the absolute URL. You’re the first one I know to try a relative URL. You are correct in that two dots should throw an error message with the verify button, but if you have your default media URL set in PowerPress settings, it can validate correctly even though it will not be a valid URL.

    Use the absolute URL and you should be all set.

    If you set your default media URL appropriately, you can enter the file name in the media URL field. Relative paths are problematic, we ertainly cannot save the data to the database that way, if the blog were to ever be moved those URLs would be invalid.

    Yep, just validated the feed, noticed the HTML comments now are removed.
    Checked iTunes and the latest episode is listed there.

    Again, thanks for replying/helping out so quick. Double thumbs up!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Trouble with Blubrry PowerPress – podcast not updating in iTunes’ is closed to new replies.