Support » Fixing WordPress » Trouble with auto-paragraphing

  • Here’s my dilemma. I’ve just finished building a template based off the Starkers theme and it’s live on the site (

    My client wants more space between paragraph breaks. No problem, I’ll just alter the CSS. Except…WP seems to be wrapping the entire post in one single <p> tag, which is really strange. I can’t alter that with CSS.

    Typing ‘enter’ into the post editor does nothing; WP doesn’t substitute
    tags for the enters, apparently. Typing a straight
    works, but I don’t want my client to have to type HTML.

    How can I fix this?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Andrew,

    That is indeed strange behavior for WordPress. Is your client typing his post directly in WordPress or is he using another software to write his posts? (i.e. Word or Live Writter).

    Usually, by pressing “enter” while typing in the visual editor, WP jumps a line by inserting the <p> tag on the paragraph above.

    Try re-installing WP (remember to backup the theme and database before, just in case) to see if the problem gets solved.

    If this helps you, please let us know and mark this post as “Solved”.


    Hey Sean, thanks for your reply.

    I will try reinstalling WordPress. This CMS is not my forte, how could I go about doing that? I’ve already made backups of the necessary files.


    Hi Andrew,

    Backup your database just out of precaution (install the “WP DB Backup” plugin, run it and download a backup to your computer).

    Then, proceed to the menu option “Dashboard > Updates”. Even if your WordPress is up to date, there should be a button written “Reinstall WordPress” (or something like it; my blogs are all in another language).

    If that fails for some very odd reason (it shouldn’t), download WordPress from and upload it thru your FTP program. Make sure you don’t upload the wp-content folder as it might overwrite your current theme and plugins. Then proceed to access your dashboard again. Once again, this shouldn’t be necessary as the auto-reinstall works fine, but just in case you have another problem 😉

    If you need any more help, please let me know.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Trouble with auto-paragraphing’ is closed to new replies.