WordPress.org

Support

Support » Installation » [Resolved] Trouble with accessing the dashboard!!!

[Resolved] Trouble with accessing the dashboard!!!

  • Hello, (Originally posted in the how to and troubleshooting category, but I think this is an installation problem so I’ve posted it here)

    I’m new to blogging and wordpress, and have just installed it on my web server… wordpress that is :o).

    Anyway, during the installation process… after I’d entered a title for my blog and email address, then logged in with the password the installation process gave me, I got this error (this error is only displayed on the dashboard)…

    Parse error: parse error, unexpected $, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /hsphere/local/home/constine/tiffanylampworld.com/blog/wp-includes/class-snoopy.php on line 656

    This is line 656…
    function _stripform($document)
    I haven’t changed class-snoopy.php at all.

    The only other bit of information I can give you is upon editing the wp-config.php file, for the line that looks like this…

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    I had to change localhost to mysql9.hostexcellence.com, because when I first went to run install.php I got an error saying something like it couldn’t connect to my database, or my database server was down. So I switched localhost to my databases host name… which is mysql9.hostexcellence.com and the error went away!

    Does anyone know how I can resolve this error? As it’s a strange one as a parse error indicates there’s some type of typo in class-snoopy.php, but that can’t be! Because the file is the file I unziped for wordpress download! Confused I am! Help I need!

    Thanks in advance.

    Nadia.

Viewing 1 replies (of 1 total)
  • I’ve fixed the problem… I deleted $document, which is the input variable to _stripform function and now I can see the dashboard and it’s contents!

    I think this error came about because I had to change the database name from localhost to my database name mysql9.hostexcellence.com, which more than likely none of you had to do, so never encountered the problem.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Trouble with accessing the dashboard!!!’ is closed to new replies.
Skip to toolbar