WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Trouble w/ install.php and config.php on Bluehost (7 posts)

  1. nmjackson
    Member
    Posted 7 years ago #

    I have signed up on Bluehost for a currently up and running blog which is on wordpress.com.

    I am in the process of moving to wordpress.org. Downloaded WordPress to the server. Have followed all the instructions, read all the documentation, read this forum, but am still having difficulty with just getting to step 2: getting install.php to run correctly so I can login to the admin.

    I need everything in bluehost to point to my temporary URL (69.89.31.161), rather than my active blog until I've imported my old posts...

    First, wp-config.php is set up as:
    define('DB_NAME', 'fitsnews_wrdp1'); // The name of the database
    define('DB_USER', 'fitsnews_wrdp1'); // Your MySQL username
    define('DB_PASSWORD', '*********automatically set I guess not the password I chose for WordPress'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    WordPress user name: nmjackson
    Wordpress password: is different than what's listed in the wp-config.php file.
    dB: fitsnews_wrdp1
    dB username: fitsnews_wrdp1
    Wordpress downloaded to bluehost to a folder called: wp

    I went to phpMYAdmin to point the siteURL to the temporary URL (from myblog.com/wp to 69.89.31.161/nmjackson/wp). But when I cut and paste "http://69.89.31.161/wp/wp-admin/install.php" into my browser I get a "HTTP 404 error, Page cannot be found" error...I've tried everything I can think of, spent hours on this...I'm sure it's a simple thing. What am I doing wrong?

    PLEASE HELP!!!

  2. nmjackson
    Member
    Posted 7 years ago #

    I also just set the "home" value in phpMYAdmin to "http://69.89.31.161/nmjackson/wp). Still no go...

  3. shadow
    Member
    Posted 7 years ago #

    Install4Free may be an option.

  4. nmjackson
    Member
    Posted 7 years ago #

    I had to uninstall wordpress and reinstall to public_html and not in a subdirectory and I also changed siteURL and home at phpMYadmin to 69.89.31.161/~fitsnews.

    Now when I go to wp-admin/install.php, I'm getting a page that says:

    Already Installed
    You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    Where/how do I do this? I'm going to search the forum on this, but if you know and can share...

    :)

    Again, many thanks!!

  5. computerfriend
    Member
    Posted 7 years ago #

    To clear your wordpress database, get into your control panel on BlueHost and Look under the Databases Bar way down the page until you find the PHPMyAdmin icon/link.
    Open PHPMyAdmin and in the left sidebar, select your database from the dropdown menu.
    At almost the bottom of the Structure tab you will see a "Check All" link. choose it, then in the dropdown menu just to the right of that, choose Empty which will empty all data out of the tables.
    Or you might choose Drop which will get rid of all the tables in the database but keep the database set up ready for your re-installation.

    Let me know if this doesn't work for you.
    Richard

  6. nmjackson
    Member
    Posted 7 years ago #

    That worked! You ROCK!

    Many thanks,

    Nancy

  7. donnabaker
    Member
    Posted 7 years ago #

    Hi --

    I am having the exact same issue. Same PHP message. However, I had deleted and rebuilt databases, so the one associated with the blog has no entries to delete.

    My next step?

Topic Closed

This topic has been closed to new replies.

About this Topic