Support » Fixing WordPress » trouble uploading

  • after reuploading wp i can’t seem to upload. when i go to the upload page it says:
    It doesn’t look like you can use the file upload feature at this time because the directory you have specified (/home/virtual/site19/fst/var/www/html/journal/wp-content ) doesn’t appear to be writable by WordPress. Check the permissions on the directory and for typos.
    i’m not sure what to do :S

Viewing 2 replies - 1 through 2 (of 2 total)
  • You have to make your uploads directory writable so WordPress can save your images to it. Don’t take as gospel the URL that it provides, either.
    In my case, I have my images that I upload in connection with day to day blogging (which is usually the kind of images I’ll upload via the WP control panel) in a directory called /images. It is NOT a subdirectory within WordPress, although you could put the folder pretty much anywhere and call it whatever you like.
    So for argument’s sake, let’s say you appease WP and create a folder called “uploads” INSIDE the folder wp-content. So in your case, the folder resides at
    Be sure that in your WP Options | File Upload Options, you specify this folder path (no trailing slash) in the box called “fileupload_realpath” and that you specify the URL (I’m going to guess in the box called “fileupload_url”.
    THEN be sure you enable file uploads by making sure “yes” is displayed in the dropdown box under “use_fileupload”.
    FINALLY, in your FTP program, CHMOD the directory /uploads to 766. That should do it!

    I am a little confused. Why does world need write priviledges for this to work?


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘trouble uploading’ is closed to new replies.