Support » Fixing WordPress » Trouble Uploading Images, Plugins etc

  • jon-ad

    (@adsynergystudio)


    I seem to be having issues with uploading images onto my wordpress. Since the new WP update and moving my files over in my FTP, everytime I try to upload a new image into Media Library, I got this message.

    Unable to create directory wp-content/uploads/2016/09. Is its parent directory writable by the server?

    So after looking through the internet forums, the most common issue seemed to be file permissions. Tried to change them in Filezilla but no luck. Apparently “500 ‘SITE’: command not understood” indicates that it won’t work because my hosting is Windows based….(my web hoster is GoDaddy and I had bought the windows based option).

    So I’ve tried downloading other FTP’s similar to Filezilla but more Windows targeted but I seem to have more of an issue simply establishing a successful connection to my domain’s IP etc.

    It’s getting to the point where I don’t know what to do, I’m out of my depth here.

    Now to top it off, I’m having problems uploading my plugins now, with the following failed message: Installation failed: Could not create directory.

    I hope the info I’ve provided for some help is enough. Please let me know if you need more. I could use ALL the help I can get. Please & thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Rinku Y

    (@rinkuyadav999)

    This is not WordPress side issue. i think, there is wrong file ownership and permission.

    Moderator Marius L. J.

    (@clorith)

    Hiya,

    FileZilla should work just fine with Windows hosting (I frequently use it my self).

    You did mention having moved this from somewhere else though, what -could- have happened is that the user and group settings carried over, which is why you’re not allowed to make changes over FTP.

    The good news is, this should be simple to fix, the bad news is that this is something you’d need to ask your host to fix (because you can’t override these kind of settings without being on an elevated account with more permissions, like an administrator account).

    So I’d start by opening a ticket, let them know that permissions are wonky on your setup, and if they could reset them to the defaults they should be.

    Hello,
    As I am acting as my own isp and I am having the same issue can you elaborate on:

    ‘let them know that permissions are wonky on your setup, and if they could reset them to the defaults they should be.’

    All files on the machine are owned and accessed by www-data and folders are set to 755, files to 644 and wp-config.php is set to 640 I believe……

    Thanks Kindly,

    Midi

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.