Support » Plugin: eShop » Trouble uploading eShop?

  • Resolved ellen_adel808


    Whenever I try to install eShop, it says there is a fatal error, therefore it will not install. When I click the “error” message, it takes me to my website hosts site which also says something like “page cannot be found.”

    How do I fix this??

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author elfin


    How are you installing? You may need to download and upload via FTP.

    I’m on my WordPress page. I click on “install/activate eShop.”
    And immediately a message comes up saying “fatal error” and warning me that no such file or directory exists.

    I do have FileZilla for my FTP uses. It’s signed on but still eShop will not install properly. I don’t know what to do to fix this error…

    Plugin Author elfin


    Sorry but I’ve not been well this week, so am still slightly frazzled and I may be mis-understanding things.

    Does eShop actually exist within your plugins directory?
    is this error when you try to activate it?


    are you unable to actually upload it to your site?either via FTP or via the add new plugin within WordPress?


    Well first I downloaded eShop from the actual site. Then I went went into my plugins, then clicked “upload” and uploaded the whole eShop (in a zip file). It said “fatal error” twice.

    So then I looked through the plugins directory that automatically shows up when I click on the plugins icon on my WordPress. And I saw “eShop” there. I clicked activate, and it gave me the same message.
    And I think it has to do with my hosting provider, possibly. Because it takes me to an error page on Bluehost (the host I’m using for my site)

    I am trying to look up the possible reasons and solutions to this problem, but nothing comes up….

    It’s really frustrating…I just got my site and WordPress 2 days ago and can’t seem to get anything right….

    Plugin Author elfin


    You’ll get there 😉

    I assume you didn’t upload the ‘zip file’ and in wp-content/plugins there is a directory called eshop filled with a load of files?

    Now if it isn’t activating it could be for a couple of reasons, and strangely one thing I suggest is to upload a single image via the media library, because usually if you can do that, eShop can create the 2 directories that are required for it to function correctly.

    But also lets rule out eshop specifically, and to do that just install a.n.other plugin – if that works then we know the issue is to do with eShop specifically. In which case let me know here and I’ll see what i can do for you. (I’m unlikely to reply again tonight though).

    Thank you for your input.

    And I just tried installing another plugin. It said it was successfully installed, but when I went to my site, I did not see it there.

    eShop just will not work. I think it has to do with my host. I tried contacting them but they said they do not deal with third party programs or scripts or anything like that.

    Ughh. If I could just get this to work. I browsed for hours on this topic and haven’t found anyone who had the same issue as me. I just need to figure out how to get rid of this “fatal error” message each time I try installing the eShop plugin…

    Plugin Author elfin


    if you want to email me privately via I’ll see what I can do.

    Ohh, nevermind. I got it fixed. But thanks for your help.

    To help anyone else out there with this issue, read this!

    So apparently the “fatal error” message was there because the name “eShop” wasn’t spelled exactly as “eShop” in my wp-content. I called Bluehost, and they took a look for me and said that my eShop folder had been renamed as something else, so WordPress didn’t recognize it, triggering that fatal error thing.

    I had to go to my file manager from my C panel and manually rename the folder just as “eShop.” And after that is was installed and activated successfully 🙂

    Plugin Author elfin


    at least that fixes it!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Trouble uploading eShop?’ is closed to new replies.