WordPress.org

Support

Support » How-To and Troubleshooting » Trouble showing previous posts

Trouble showing previous posts

  • Hi,

    I’m having trouble with my blogroll. It’s currently shows the last two posts I’ve made but it indicates “page not found” when you try and go three or more posts back. All the posts are published but for some reason they are not showing up.

    My site is located at: http://www.travislocke.com/home/

    Any ideas what could be causing this?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Is it possible that the number of pages shown (one, I think) does not agree with the posts_per_page setting?

    If your posts_per_page setting is 10, for instance, but you only display one post, then the ‘Previous’ link would fail on page 3 if there are less than 30 posts.

    As an experiment, go to Admin->Settings->Reading and if ‘Blog pages show at most’ is set to more than 1, set it to 1 and see if more pages work.

    That worked great! I didn’t realize it could be that simple. Thanks for helping.

    That may not be the best solution, only a way to see if the template that displays the page has a problem.

    You really should fix the template by altering the Loop. Since there are many different ways the template could be coded, it isn’t possible to tell you exactly which file should be changed, or what to change.

    If the setting is not causing other problems in your site, just leave it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Trouble showing previous posts’ is closed to new replies.