Support » Plugin: Gravity Forms Salesforce Add-on » Trouble Passing Picklist (Multi-Select) Data to Salesforce

  • Hello,

    I currently have 3 gravity forms running on my website. I’ve managed to map all fields correctly to Salesforce for each form, using the “Web-to-Lead Feed” function in the Salesforce add-on (v 2.5.2). Well, all expect one. I’m having a bit of trouble getting checkboxes in Gravity Forms to pass data to the corresponding picklist field in Salesforce. The following form is probably the trickiest: http://www.lac-group.com/research-metadata/r2s-services/reports-alerts/sample-reports/

    In form, you’ll notice that there are two checkboxes present under “Please select the report(s) you wish to receive.” In Salesforce, I created a new picklist field for all Leads, called “Sample Report Requested.” The values for this picklist correspond to the checkbox options in the form, which are “Expert Witness Report,” and “Company Intelligence Profile.”

    When I submit a form using Gravity Forms, I have success getting the data to pass through Salesforce for all fields except the Sample Report Requested field; this field is left blank. I’m wondering what I might be doing wrong here. Any advice on how I might correct this?

    I should note that I have had success passing data to Sample Report Requested field in Salesforce using the “Salesforce feed” function with the add-on. However, I choose to use “web-to-lead” function, after having too much difficulty getting Salesforce auto-responders to fire using the feed option.

    Thanks for your help!

    -Rob

    http://wordpress.org/plugins/gravity-forms-salesforce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Zack Katz

    (@katzwebdesign)

    Try following these FAQ directions: “Web-to-Lead: My input values are being cut off in Salesforce”

    I tried updating my functions.php as per the FAQ. Still doesn’t work.

    Seems to be a pretty common theme here. Has anybody actually gotten this to work properly?

    If so, please post a detailed description of how that was accomplished.

    My comment is about Mutli Select Gravityforms field…

    After looking into how the code of the plugin works I figured out that the plugin checks the type of the value and if it is “array” it applies the “gf_salesforce_implode_glue” hook implementation.

    The problem though is that the type of the value of Multi select field is a string with the values separated by the “,” (not array). So the hook is never fired.

    I did that with the latest version of GF (1.8.19) and the Salesforce Add-on (3.0.6.3) plugins.

    Anton

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Trouble Passing Picklist (Multi-Select) Data to Salesforce’ is closed to new replies.