WordPress.org

Support

Support » Installation » [Resolved] Trouble moving WP to new server, same domain name

[Resolved] Trouble moving WP to new server, same domain name

  • I’m in the middle of switching hosting providers, and I’m having trouble getting WP up and running on the new host. Just visit http://www.desperatevalpo.com to see the error message I’m getting. It looks like this:


    Warning: main(/home/.parthine/livingh/desperatevalpo.com/interact/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/.parthine/livingh/desperatevalpo.com/interact/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/.parthine/livingh/desperatevalpo.com/interact/wp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /home/.parthine/livingh/desperatevalpo.com/interact/wp-settings.php on line 39

    Any ideas? The domain name is the same. I followed the “moving your WP installation” steps in the Codex and at Tamba2.org. It’s WP 1.5.1, I think. I created the new database with the same name, same username, same password, as on the old host. Only the DB_HOST changed in wp-config.php.

    I’m stuck. This is the first time I’ve tried moving a WP blog. And if it helps, I’m moving from churchquest.com to dreamhost.com.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Oh, I should mention, that the blog is installed in the “interact” directory. The root level index.php is a static front page that accesses files. But I can’t get into the admin pages or anything…

    Mark (podz)

    @podz

    Support Maven

    The failed opening is saying that the file mentioned isn’t there. Have you checked all the files have uploaded correctly ?

    I actually had a very similar problem myself not too long ago when I was switching servers. I found that re-uploadeding the WordPress files seemed to correct the issue.

    I’ll try that. I think all the files are there, but I’m not sure. I thought maybe it was a PATH issue… but maybe the upload partially failed. Thanks!

    Best of luck, richschmidt!

    Good grief! The files uploaded OK… but they hadn’t all downloaded from the previous server! SmartFTP kept crapping out on me while I was doing that, and I didn’t even notice that it missed half my files. I didn’t even have a themes folder! I’m re-downloading & uploading now…

    Doh!

    Aack. All the files are there, but they’re spitting out errors, and now I can’t login to the admin panel. Good grief.

    Oh well. Thanks for the help!

    Fixed it. Some of the files must have been getting bonkered in the upload. I just had to keep overwriting files until I fixed it. (One little plug-in file was getting goofed up somehow…) Seems to work now! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Trouble moving WP to new server, same domain name’ is closed to new replies.