Support » Plugin: Advanced Custom Fields: Font Awesome Field » Trouble loading icons in ACF editor

  • Resolved wwhite4890

    (@wwhite4890)


    Hello,

    I’m running into trouble getting the icons to load in ACF. When I select the option for Font Awesome Icon and go to select a default, no icons are loaded.

    If I inspect the page when this happens, I get the following error:

    Uncaught TypeError: acf.escHtml is not a function
        at args.escapeMarkup (input-v5.js?ver=3.1.2:42)
        at d.e.display (select2.full.min.js?ver=4.0:1)
        at d.b.createPlaceholder (select2.full.min.js?ver=4.0:1)
        at d.j [as createPlaceholder] (select2.full.min.js?ver=4.0:1)
        at d.b.update (select2.full.min.js?ver=4.0:1)
        at d.j (select2.full.min.js?ver=4.0:1)
        at d.c.update (select2.full.min.js?ver=4.0:1)
        at d.j [as update] (select2.full.min.js?ver=4.0:1)
        at e.<anonymous> (select2.full.min.js?ver=4.0:1)
        at e.d.invoke (select2.full.min.js?ver=4.0:1)

    Theme: Understrap

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    The escHtml function that you are seeing the error about is part of the JS from the Advanced Custom Fields plugin that this plugin relies on.

    I wonder if you are using an out of date version of that plugin that doesn’t include this code? Or if there is some other issue preventing the ACF javascript from running?

    The first step here would be to make sure you are on the latest version, 5.10.2 at the time of writing this.

    Thread Starter wwhite4890

    (@wwhite4890)

    That was the cause of it! Sorry, I should have thought to check that first. Thank you so much for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.