WordPress.org

Forums

Virtue
[resolved] Trouble listing 3 products per row on woocommerce (11 posts)

  1. Joseph
    Member
    Posted 10 months ago #

    I am using Virtue 2.1.7 and I have trouble sorting my woocommerce products. I need to sort them by id or date (desc).

    Right now it returns my products like this:

    Row 1 (ID's): 983, 985, 981
    Row 2 (ID's): 976, 979, 974

    As you can see, the numbers are not listed descending. It is a theme related stuff because if I change the theme the trouble disappears.

    I have changed the products per row number like this:

    add_filter('loop_shop_columns', 'loop_columns');
    if (!function_exists('loop_columns')) {
    function loop_columns() {
    return 3; // 3 products per row
    }
    }

    Any idea how to fix this issue? Maybe some CSS fix?

    Thanks!

  2. Kadence Themes
    Member
    Theme Author

    Posted 10 months ago #

    Post a link, why not update to the latest theme?
    if your products are different sizes then the order would be off.

    Kadence Themes

  3. Joseph
    Member
    Posted 10 months ago #

    Here is a page where you can see the problem. I have added the post ID so you can see the order. See the line starting with product nr 983.

    I cannot update to the latest theme because I customized the old one.

  4. Kadence Themes
    Member
    Theme Author

    Posted 10 months ago #

    You should be doing all your theme file edits in a child theme.

    Just go into the theme options > shop settings and increase your product title min height to 60 or 70px.

    Kadence Themes

  5. Joseph
    Member
    Posted 10 months ago #

    Thanks, that did the trick!

    I am not sure how to work with child themes so I edited the original file..

  6. Kadence Themes
    Member
    Theme Author

    Posted 10 months ago #

    You might as well learn now, it's not going to get any better for you the longer you wait:

    http://codex.wordpress.org/Child_Themes

    Kadence Themes

  7. Joseph
    Member
    Posted 10 months ago #

    Thanks. That was easy! I managed to create a child theme. :)

  8. Joseph
    Member
    Posted 10 months ago #

    One more thing.. If you check the same page with Mozilla Firefox you'll see that the last (3rd) column does not stay there. When the page is loading it is in its place, than it disappears. Why is that?

  9. Kadence Themes
    Member
    Theme Author

    Posted 10 months ago #

    Just looked and didn't see this.. which version of firefox do you have??

    Kadence Themes

  10. Joseph
    Member
    Posted 10 months ago #

    I have fixed it in the meantime and forgot to updated the status here. Sorry for that! Thank you for your support!

  11. MB-Images
    Member
    Posted 8 months ago #

    It seems like I have the same problem now with firefox. Everything looks fine in IE and Chrome, only in FF I can't get a 3rd column. So could you tell me how you fixed it? Thanks

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.