Trouble installing wp supercache (6 posts)

  1. n0body
    Posted 8 years ago #


    I tried to install wp-super-cache. I think I followed all the steps correctly. Here is the error I get after enabling "WP Cache and Super Cache" in the options of WP Super Cache :

    Warning: sem_get() [function.sem-get]: failed for key 0x152b: Permission denied in /var/www/html/xxxxxxxx/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 100

    supercache plugin version : 0.5.1
    wordpress version : 2.3.1
    themes installed : BloggingPro Theme - Widgets Ready 1.2
    other plugins : most commented, recent comments and recent posts

    When I access a page for the first time (the main page of the blog for example), I see the error message, When I'm in the admin of wordpress, I always see the error message. When I access a page, a file (or some files) is created in the cache folder, but in the admin of WP supercache, there is "0 cached pages" for WP-Super-Cache but 2 for WP-Cache.

    I tried chmod 777 on the cache directory
    I tried deleting the cache directory
    PHP safe mode is off
    I deleted the wp-cache var in wp-config
    I tried with php 4.3.10 and I upgraded to 5.2.0, still the same behavior.

    Any idea?

  2. Donncha O Caoimh
    Posted 8 years ago #

    Are you using PHP safe mode?

  3. n0body
    Posted 8 years ago #

    No, like I said php safe mode is "off" (I checked with phpinfo)

  4. Donncha O Caoimh
    Posted 8 years ago #

    Sorry, I don't know why you're getting a permission denied error then. You could try file locking.
    Edit wp-content/wp-cache-config.php and uncomment the $use_flock line.

  5. n0body
    Posted 8 years ago #

    It seems to work fine whit the "use_flock" line... What is it ? Do I lose a functionality with this ?

  6. Donncha O Caoimh
    Posted 8 years ago #

    Nope, it's just a different way of doing file locking. Look through the source :)

Topic Closed

This topic has been closed to new replies.

About this Topic