Trouble installing wordpress-3.5.1 (7 posts)

  1. barnali
    Posted 2 years ago #

    Hi everybody.

    We have to install a new wordpress for every new site. Else we can update the wp-config.php file with the latest database and username info. This is what I get through the form.

    Please do rectify if the above context is wrong.

    Well the problem is I have tried every possibilities by installing a new wordpress and by changing the the database, user name etc. etc. in the wp-config.php file, nothing is working and I cannot install the new wordpress. In both the cases it shows the same error

    'Error establishing a database connection'

    host is localhost

    please guide.

  2. Joni
    Posted 2 years ago #

    Did you create an actual database? You do this by visiting your web hosts control panel. AND don't forget you should add a user (with a password) to that database. It does no good to create a database and forget to add a user. (I do this ALL the time!)

  3. barnali
    Posted 2 years ago #

    Thanx for the responce.

    I had created a new database in phpmyadmin. Is this what you are saying about.

  4. Joni
    Posted 2 years ago #

    Yes. But did you also create a user and ADD that user to the newly created database?

  5. barnali
    Posted 2 years ago #

    this is what I added
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'jw-db');

    /** MySQL database username */
    define('DB_USER', 'jw-dbuser');

    /** MySQL database password */
    define('DB_PASSWORD', 'xxxx');

  6. Joni
    Posted 2 years ago #

    Your user name is only two letters; that seems short to me. Are you sure that is correct?

    And make sure you ADD the user to the database (from within cPanel). You have to actually add it. Sometimes people forget that just creating both is not enough.

  7. barnali
    Posted 2 years ago #

    Thanx for the info. I tried this out but not working. I will re-install the WAMP server and repeat the process again and get back to you.

Topic Closed

This topic has been closed to new replies.

About this Topic