[resolved] Trouble Installing Thematic Child Theme (9 posts)

  1. emmaconstance
    Posted 2 years ago #

    I am new to WordPress, but I have searched up and down for the solution for my problem and no other issue seems to be similar to mine.

    I copied the "thematicsamplechildtheme" folder info (style.css, readme.txt and functions.php) into my new child theme's folder in the root level of wp-content/themes just as the readme instructed.

    However, when I go to install the theme on my WordPress page it says that the theme is installed by incomplete because the stylesheet is missing.

    This is the stylesheet provided with my edits. Again I am completely new to this so it is very possible that I just don't see something:

    Theme Name: EC's Thematic
    Theme URI: www.emmaconstance.com
    Description: A Child Theme Based on Thematic
    Author: Emma Constance
    Author URI: www.emmaconstance.com
    Template: thematic
    Version: 1.0
    Tags: white, three-columns, two-columns, fixed-width, theme-options, left-sidebar, right-sidebar, threaded-comments, sticky-post, microformats
    License: GNU General Public License v2.0
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    The Thematic Theme is copyright Ian Stewart http://themeshaper.com/
    This work, like WordPress, is released under GNU General Public License, version 2 (GPL).
    /* Reset browser defaults */
    @import url('../thematic/library/styles/reset.css');
    /* Apply basic typography styles */
    @import url('../thematic/library/styles/typography.css');
    /* Apply a basic layout */
    @import url('../thematic/library/layouts/2c-r-fixed.css');
    /* Apply basic image styles */
    @import url('../thematic/library/styles/images.css');
    /* Apply default theme styles and colors */
    /* It's better to actually copy over default.css into this file (or link to a copy in your child theme) if you're going to do anything outrageous */
    @import url('../thematic/library/styles/default.css');
    /* Prepare theme for plugins */
    @import url('../thematic/library/styles/plugins.css');
    /* Overriding Thematic's styles for congruity with WP-Admin > Appearance > Header default header text color settings */
    #blog-description { color: #000 }

    Thank you for your help!


  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Try asking on their dedicated forums:


  3. Gene
    Posted 2 years ago #

    Could is be a file naming issue. Is the stylesheet neamed style.css?

    Could it possibly be a permissions issue. Is the style.css word readable? Try 644 on the stylesheet.

    Also the link WPyogi offered up doesn't work Try this one: http://thematictheme.com/forums

  4. emmaconstance
    Posted 2 years ago #

    I did go to the dedicated forums to ask. The original style.ccs is readable. It is so strange. It happened when I originally tried to write my own child theme, too. I believe that I am saving them to the correct place (in the root level of wp-content/themes). Could the issue be outside of the code?

  5. Gene
    Posted 2 years ago #

    You mentioned above:

    The original style.ccs

    The file should be named "style.css" not "style.ccs" or was that a typo in the comment above?

  6. emmaconstance
    Posted 2 years ago #

    Oops, that was my own typo. So sorry...

  7. Gene
    Posted 2 years ago #

    Still no joy? I see that Scott had responded to you at ThematicTheme.com

  8. emmaconstance
    Posted 2 years ago #

    No luck! However, I have responded to Scott.

  9. Gene
    Posted 2 years ago #

    Anyone having similar issues should look here to see how Emma resolved her problem.

Topic Closed

This topic has been closed to new replies.

About this Topic